YPbPr Color Mode


I’ve been using the Vero 4K+ for two months, and it has been working very fine. Since the latest update
(october or november, don’t remember) the color mode is not being set correctly, as did before. I have the Vero4k connected to a Onkyo Receiver, in 1080p mode (not 4K).

I don’t know exactly what mode defaults the Vero4K, but I have my projector configured to YPbPr, and many times when I start up the mode is set to RGB. I have noticed that if I start the Receiver connected to the Blu Ray (instead of the Vero), and then I restart the Vero, sometimes it starts with YPbPr mode.

I know there is a setting to “Force RGB”, but I can’t see the option to force YPbPr.

Any ideas?

Vero will use YCbCr (aka YUV) by default. It will only use RGB if it’s set explicitly or your display indicates no support for YUV in its EDID.

Please post a debug log for the case where your projector is at RGB.

Can you check that it’s not the case that this only happens if you start Vero before your receiving equipment is turned on?


I have not yet been able to debug the system, but I’m sure that when the Vero starts all the equipment is turned on. I checked it last week because I knew there can be problems when the devices do not respond to the EDID messages.

Anyway, I usually do not power off, I only suspend. Is it normal that if I suspend in YUV mode, the mode changes when I take it out from suspension? This happened to me last week, which I thought it was strange.

I’ll try to debug this night.


We added support for hotplugging; so you could now move between displays or EDID updates.

This could trigger a change. The logs would help a lot

How does the hotplugging work exactly? I have the Vero connected to the receiver, and the receiver outputs to the tv and the projector, so depending which of them is powered on, the vero will detect differents EDIDs. Maybe this is the problem. But both of them are YUV capable, so the default should be YUV.

I’ll try to upload the logs…


If there is an HPD event, we parse the EDID for updated resolutions again.

Here is the log:


When I restarted the system, the screen was ON, and also the receiver. It seems that the screen settings are getting the fallback configuration, but I don’t know why exactly.


Please post full logs using MyOSMC or grab-logs -A.

Sorry, I thought that kodi.log was the full log, and since it was easier for me, I simply copied it in pastebin.

I’ll try to upload the full log this night. Can I do it using MyOSMC addon, or do I have to do it exclusively with grab-logs?


Yes, you can.

OK, I think now I got the correct log:


Any idea why the color mode is not selected correctly?


You have Force RGB output turned on in Settings-System-Display.

The point is that I want it to be configured as YUV, because the Blu Ray and projector are this way, but when I connect the Vero, sometimes it changes to RGB, and I have to change my projector configuration, and then again when I connect to the Blu Ray.

I don’t know why the Vero is changing the color mode. Someone can see something from the logs

(Maybe in options there could be an option to force YUV also…)



Change this setting to turn RGB off and re-boot. To see the setting, you have to set your settings level to Standard, Advanced or Expert.

Sorry, that setting should not have to be on. I tried many things and at the end I let the RGB mode on and projector to RGB to be able to use it without changing the settings every time it boots up.

THIS is the log without the RGB mode on, the projector set in YUV mode, and after reboot, the Vero does not output YUV, but RGB.


Sorry for the “Force RGB error”!


Dec 02 23:26:25 osmc kernel: hdmitx: video: VIC: 16 (16) 1920x1080p60hz
Dec 02 23:26:25 osmc kernel: hdmitx: video: Bit depth: 10-bit, Colour range RGB: limited, YCC: limited, Colourspace: YUV444
Dec 02 23:26:25 osmc kernel: hdmitx: video: Colorimetry: bt709
Dec 02 23:26:25 osmc kernel: fb: osd current vmode=1080p60hz, cmd: 0x10000
Dec 02 23:26:25 osmc kernel: fb: osd[0] enable: 1 (kodi.bin)

This is telling me we are sending YUV. You can double-check by typing at the commandline
cat /sys/class/amhdmitx/amhdmitx0/config
I don’t know what to suggest, really. Can it be an issue with your AVR?

Thanks for the info. I will look after it again and test with the commandline, to see what is happening.