Zattoo tv addon does not work

Hello, there is a problem with the zattoo tv addon, look like there is an update here:

How can i update it in the osmc?? thank you

Download the .zip from the link you pasted. Install from zip file from within the addon browser.

sorry , what zip file?

EDIT: i tried to install the zip, it says: failed to install , invalid structure

What is the problem?

I think he downloaded the git, not an addon, and it has to be built.

Zatoo is a PVR add-on, and therefore a binary add-on.

I’m trying to ascertain what the issue is, to verify it is indeed fixed for v19 (we won’t backport / patch 18.9 further)

There is a bug in the old version, someone fixed it, this is the new version but look like it dorsnt work with osmc Release 18.1.23-Leia: Merge pull request #115 from rbuehlma/bugfix/loading_app_token · rbuehlma/pvr.zattoo · GitHub

Hey, I can confirm that version 18.1.23 fixes the issue for zattoo pvr. The plugin has to be compiled for your platform if you don’t want to wait for it to be updated in OSMC.
There is a zip file for raspberry pi over there : PVR-Addon für Zattoo (und Reseller) - Seite 40 - IPTV - - Deutschsprachiges Forum zum Kodi Entertainment Center (in german…) page 53 post by Timmiotool

1 Like

I managed to build the working addon with these commands:

sudo apt-get install git autoconf cmake zip build-essential

git clone --branch Leia

git clone --branch Leia

cd pvr.zattoo && mkdir build && cd build

cmake -DADDONS_TO_BUILD=pvr.zattoo -DADDON_SRC_PREFIX=../.. -DCMAKE_BUILD_TYPE=Debug -DCMAKE_INSTALL_PREFIX=../../xbmc/addons -DPACKAGE_ZIP=1 ../../xbmc/cmake/addons

make package-pvr.zattoo

We can use another plugin: zattoo box , here there is the issue fixed:

i installed the ZattoBox 1.0.7 , but still the issue is not fixed.

2021-02-19 10:36:31.714 T:4068880400   ERROR: Control 55 in window 10025 has been asked to focus, but it can't
2021-02-19 10:36:40.506 T:4068880400   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://]

You have to edit manually and

Dear Rito_Bear, thank you for posting these instructions; they have solved my issue (could not install the precompiled add-on from a downloaded zip file). I just had to shut down the media center before git cloning due to insufficient memory in my Raspberry Pi 3A :laughing:

sudo systemctl stop mediacenter

and find the zip file to be installed after the build in

So thanks again!

1 Like