ZeroTier on OSMC not connecting

I have installed ZeroTier on the RPi version of OSMC, which runs on Debian Bullseye. The OSMC box is reporting it’s connected to the ZeroTier network, but I cannot access it over SSH. SSH is enabled on the OSMC box and I can SSH to it locally. All other devices can connect to each other on the ZeroTier network, but OSMC will not connect to any other device and when I try to ping it I get;

❯ ping -c 3 [IP_ADDRESS]
PING [IP_ADDRESS] ([IP_ADDRESS]) 56(84) bytes of data.
From [HOST_IP] icmp_seq=1 Destination Host Unreachable
From  [HOST_IP] icmp_seq=2 Destination Host Unreachable
From  [HOST_IP] icmp_seq=3 Destination Host Unreachable

--- [IP_ADDRESS ping statistics ---
3 packets transmitted, 0 received, +3 errors, 100% packet loss, time 2053ms
pipe 3

The actual addresses are redacted obviously, but I cannot for the life of me figure out what is going on, and networking is not my strong point. Any ideas?


Never used it and not sure what it is. Is it a VPN?

Have you tried contacting them?

Hi. Is the device you are pinging from also on Zerotier? I’m wondering if the Vero uses the /etc/hosts.allow and /etc/hosts.deny and maybe you need an entry to allow sshd such as sshd:, LOCAL


Hi, I installed zerotier on a rpi 4 and a Verok4k+ following the short ‘get started’ instructions on their web site and it worked out of the box. Actual I only have two ideas:

  • Did you authorized your new device on your zerotier network?
  • Typical they use a 172…/16 private network and you have different ips in the last two bytes. You may have chosen the wrong ip for your ping test?

Can you ping the shown external/physical IP on the network page of