Zomboided NordVPN and DNS

All of a sudden my Zomboided VPN Manager no longer connects to NordVPN. The message I’m getting is authentication failure however I am 100% sure username & password are correct since they work online and in the app. I also changed the password to ensure it no longer contains special characters (since I’ve read NordVPN API might have issues with special characters). No luck. My connection is all right it’s only NordVPN that can’t connect. I tried re-installing Zomboided (for Kodi 19) but still no luck.
In the past there used to be a dns issue with NordVPN specifically which I bypassed adding the NordVPN dns servers directly into resolv.conf. I’ve checked and those IPs haven’t changed however for some reason I’m no longer able to ssh into my Vero 4k+ to double check. I tried local access, remote ssh via ip… again I’m getting access denied as id credentials are incorrect although I’ve always used the default osmc/osmc and now they seem no longer working.
Any ideas?

Zomboided 7.0.2 and logging in with token instead of user/pass.

1 Like

I couldn’t logon either via Kodi, Firestick worked fine. The newest Zomboided should fix it for you.

Thank you so much! I had just read the news of NordVPN changes in the issues of Zomboided github repo. The problem was that I was running the version for Kodi 19 and it didn’t detect any update

What about my issue with ssh however?? How come osmc/osmc gives me access denied?

Are you sure you’re logging in to the right box?

Is your device exposed to the internet? It may have been compromised.

I’m trying both locally exiting from the power menu and remotely via ssh on the LAN ip. I don’t think port 22 is publicly open on my router.
It says access denied
What can I do to get back console access?

Personally – unless you changed the password, I’d consider that system as compromised and format it right away. I would not even take a backup.

You should reinstall OSMC now and giving you other suggestions would be a disservice to you and your network.


Thank you all for the support received. With the Zomboided issue resolved, my only outstanding issue is being unable to sign-in the console locally/ssh using the default credentials osmc/osmc (as per documentation).
I might be wrong however I don’t remember changing them.
I don’t believe I have a security issue since I have double checked and I don’t have ports open.
In any case how would I reset it completely to start over? What’s the procedure?

Many thanks

You can reinstall from Download - OSMC.