Zoom Video (like the mplayer keys "e" and "w"

Hi all,
I am replacing my old Gentoo based Nettop with OSMC. This is great but I am looking for a certain feature with I had used with my smplayer on the previous system:

Some of my videos are poor recorded, the video frame is much smaller that the screen. In this case there was a mplayer zoom feature using the “e” and “w” keys. Note: I do not mean the overscan feature because everything else, including the UI, fits perfectly.
Is there a similar function in the osmc video player? This would be great. But I did not find it so far.
Best regards


Thanks, but there is nothing which can do that. “z” for “zoom/aspect ratio” just creates a dialog which contains one button (DVD standard). Pressing that doesn´t change anything.

So pressing z repeatedly while the dialog is open doesn’t cycle through several options ? Pressing z then waiting for the dialog to go away will not change anything, it will only display the current display mode.

No, pressing “z” twice let just disappear the dialog. Pressing again and it appears again … and so on.

Does z work properly if you switch to the Confluence Skin ? When you press z repeatedly the dialog should stay open and cycle between about 5 different screen size options.

I am using the Confluence Skin! It does not circle between different option. Like mentioned above, it only shows “DVD Standard”.

Not sure then sorry. For me, Z cycles between different presets such as “Normal” “Full Screen” “Widescreen” and so on, (not the exact names) and I have not heard of the Zoom function not working before.

May this be platform dependent? I am running on a raspberry pi 2.

Works for me on RPi2

And me. I was testing on a Pi 2.

Hmm, this is strange. I just downloaded the image and flashed it on a sd card. The hardware is identical. How can this be different? The only customizing I did was connecting to my NFS Server.

I found the reason. Please don´t hurt me :wink: It was really simple. The keyboard layout switch from english to german did not work, it is still english even I selected german. The result is that the expected feature works when pressing the “y” key instead of “z”.
Thanks for your help!