Zooming leads to mixed up colours

With certain movies my Vero 4K consistently shows mixed up colours, if I use certain zoom factors. No crash, just colours completely off. Not all movies, but so far I haven’t been able to detemine what they have in common. See attached pictures.
In one instance I could get good colors on zoom factor 1.00, 1.01, 1.03, 1.04, 1.05, 1.11, 1.19, 1.21, 1.23, 1.26. All intermediate zoom factors give the same weird colours. Zooming below 1.0 doesn’t seem to cause problems. I’ve used the Vero 4K a few years now, never seen this before. It seems to happen since the January update. I tried various output devices and cables, no difference.
Is this a known issue?

Yes it is. Try updating manually.

I’m running OSMC January 2023 2023.01-1. A manual update told me there is no update available. Now what?

Ok, maybe the fix hasn’t been released yet. If it’s crucial for you you can update from ‘staging’ repo, but I suggest you just pick a zoom level that is stable and the update with the fix will come soon.

Thanks for your help, Graham. I can live with the work-around until the fix is available, no worries.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb http://apt.osmc.tv bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

I’ve run the commands you suggested, and I’m happy to report that the problem seems to be resolved!

Many thanks!