10 bit and banding fixed?

Edit: this is now fixed in the latest software.

Has the 10 bit HDR issue been fixed in the june update? Auto detecting I mean :slight_smile:

It’s improved but may not yet work completely for you at this time. This is covered in some other posts.

It will all be wrapped up by July

Cheers

Sam

1 Like

Sam, I have an HDMI 2.0 lite board which tops out at around 11gbps

Blu ray players and some other devices can do 24hz 4:2:2 10bit

This is primarily what i bought the Vero 4k for - but there is no selection for this like the Shield and I don’t know how to engage it - it switches to HDR ok, just 8 bit.

Sorry, new… everything else seems to work ok.

You can enable 444,10-bit manually.

Remember that HDR and colourspace output are not the same.

Cool. And how do I do that? Pretend just for a moment I’m a newbian princess.

Thanks!

No problem. Do you know what SSH is?

There’s a way to enable this option without any command line knowledge, but you may need to revert it if it’s not suitable for your settings.

Could you also go to My OSMC -> Logs -> and send me the URL after uploading all logs so I can see the capabilities that your display (and connected peripherals) are advertising?

Sam

Yep I’ll do it when I’m back from the gym.

Cheers.

1 Like

@sam_nazarko

https://paste.osmc.tv/locapuvepu

JVC5900 display which has an 18gbps chipset in it.
Lyngdorf MP50 processor which has HDMI 2.0a but it’s capped around 12gbps roughly - however all UHD Blu Ray players will out put a 10bit HDR image thru it.

It would be nice to see an HDMI colourspace select mode like the Shield in a future build. I got the Vero 4k in hopes it could do the 10bit thing. I’m pretty sure the Nvidia Shield even with the Oreo update may still suffer from banding. I can’t test it because I can’t select the mode.

Thanks!

r.

Hi

I will check this shortly when back at my desk.
I can trivially add colour space selection and bit depth but as I’m sure you know, it depends on output resolution. This could cause confusion.

I think what may make more sense instead is to have an option to enable 10-bit output and we use 444 or 420 where appropriate

Sam

Yes possibly. I just found the match refresh rate to movie setting in player settings and it will either crash and blue screen on me or play the movie and when stopped return to the GUI in pink & green*. This is with 4K HEVC MKV - I will try noodging the GUI back to 1080p to see if that stops it or I’m not sure if I need to maybe add a larger delay in the handshake?

I’ve seen Kodi do this with the Lyngdorf gear, It’s fine with the Shield and other stuff could just be a few cheeky tweaks needed… hopefully.

The board update for my processor is $1,000 when released this August… I feel faint.

*Edit: Leaving the GUI on 1080p seems to solve the green /pink or lock up issue. Coming out of a 4K movie back into a 4K GUI.
Edit2: Nope, still happens. damnit!

I’m shattered – so I’ll pick this up tomorrow.

Cheers

Sam

No worries, sleep well. It’s not playing ball with matching framerates. So it’s borked till a fresh brain Inspects it.

Thanks!

@sam_nazarko Just to add. Having refresh rate set to ‘Always’ or ‘on start / stop’ will result in a crash of any 4k HDR HEVC MKV files.

The movie will start and the goes blue no sound, I can back out of the blue screen and the movie will be playing behind the GUI or stop the movie and it will return to GUI as normal.

Sometimes however, it works and plays the movie (of several tested) but I’d say it has a fail rate of +90%

Tried all settings in the processor - files working ok on Shield (with Kodi and Plex) and HTPC, no handshake issues on any other device. All movies fine @1080p.

The higher bitrate stuff does freak the box out a bit if you jump several chapters, but I accept that this may be because of Samba - altho again, it’s not a problem on other Samba V1 enabled devices.

I’m off to London tomorrow for a week or 10 days ( I think ) happy to try solutions or do I send it back?? Not sure what to do?

thanks!

Hi,

Sorry for the late reply – I’m away from Monday so have to wrap some things up.

Firstly, for Adjust Refresh Rate to work correctly, you should set the GUI to 1080p. This will give you the best experience as Kodi’s scaling is probably not as good as your display.

Can you confirm if you have HDR autoswitching enabled? I think this may be the reason that you experience a black screen occasionally.

The HDR autoswitching can be hit and miss. It currently sets 444,10-bit output if activated, but the detection doesn’t work for all formats just yet. When it does detect and switch correctly, it’s likely pushing your display in to an unsupported mode.

Can you go to Settings -> Logging -> and enable Debug Logging?
Reboot, so the logs aren’t too large.

Play a video, and if you see a picture, go to My OSMC -> Logs and send me the link.
Then if you can reboot again and get me a link when you don’t see a picture.

This will let me see what’s going on and also see your display’s capabilities.

We should be able to get this working for you.

The next update has improvements for seeking and some RX performance improvements (about 4-5Mbps extra throughput in the real world).

Sam

Where is the hdr auto switching located?

I hope it gets optimized soon. I dont wanna have to enter all sorts of code to get it working :slight_smile:

Settings -> Display -> HDR autoswitching.

Or, to enable it more persistently:

You can also go to updates -> manual controls -> apply hotfix and type:

[deprecated]

Don’t enable both

Thanks Sam, I’ll hopefully get that done before i leave tomorrow. I had enable HDR autoswitching on and when I turned it off it worked for a while then chucked a wobbly. Gui was on 1080p at the time, tried it at 2160p too.

The problem may be based on the limitation of this 11gbps board and JVC projectors have a notoriously long handshake time (around 11 seconds) I’ve seen something similar on custom installs with skyQ boxes - they won’t lock on to 4K if the handshake is too long - you gotta set it on a 4K TV set then install it alongside the JVC.

Joys of HDMI…

Yes – sometimes a long cable causes this problem.
I have a long run for my projector and had similar problems (perpetual handshaking), which was resolved by using a better quality cable.

Sam

I’m using a 10m fibre optic from Monoprice Slim run series, only this and the Ruprio passed all the Muedeo (test gear) and real life installs with everything. This was done in a massive cable shootout by a buddy of mine that has his own CI AV company… he has all the toys!

Sounds like a shortcoming of the JVC then.

Sam