[17.5 update 2017.10-1]Broken Playback videos issues

Before I also restored my configuration file on a new install of 17.5 update 2017.10-1 with the same problem.
For now i think i will use the previous build that is working… but i fear the next update

There don’t really seem to be other reports of significant playback problems post-update.
But unfortunately if you stay on an old version, we won’t be able to fix things.

Sam

Sam, i’m willing to help and thanks again for your consideration.

I posted full logs… and reviewed all my setup.
I will try another update tomorrow and will keep you informed.
My only concern is that debugging takes times and can’t watch TV at the mean time.

The logs you provided unfortunately did not have debug logging enabled as per our instructions on how to provide such logs. Without debugging enabled they are less verbose than we need in order to get a good picture of what is actually happening on your system.

Also, you seem to be running a build that is not supported by OSMC or Kodi. That being the case, the first thing we must confirm is that the issue exists without the build or any other illicit repos or addons installed.

@ActionA

Thanks for the insight.
I only playback local files.

Because I’m the only person to have this issue after the update, will it be faster/better for you that i uninstall this and try without it ? or i could make a fresh install ?
Regards

Fresh install solved the issue, Ty

Thanks for reporting back.

I’m glad it’s resolved now.

Sam

The issue reappeared after i’ve restored my advancedsettings.xml
when i delete it it work again

https://pastebin.com/hJniqQGh

What changes did you make in that file?

sorry, Sam i updated my post, it was missing the Pastebin

advancedsettings.xml was working with the 2017-8-1

Probably this is related to : Buffer issues after October Update - #17 by dillthedog

You have a readfactor of 10 with your highbit videos and your slow connection it will take quite a couple of seconds till that is filled

it used to work well and now i tried different values and none of them are working for now
when i remove advancedsettings.xml everything is getting back to normal. Larger video files will need buffer…

Which is no wonder if your LAN is only having 55Mbit.

advancedsettings.xml with whatever values is causing a playback issue With HD and UHD files

I just read Kodi : http://kodi.wiki/view/HOW-TO%3AModify_the_video_cache

Update :

I directly connected the vero 4k to my Gb router to make sure i will have the max bandwidth available
advancedsettings.xml is still causing an issue… i did try a lot of different values.

I don’t understand…

55Mbit LAN bandwith + enough buffering is more than OK and solid.
Wifi is not as stable and bandwidth easily drops and causes frequent buffering.

Even if it takes 5-10 sec to fulfill the buffer the player will have extra cache before it stops
Before the update, I’ve been able to read up to 40GB UHD file with no issues at all.
Only UHD files require bigger cache

Not sure what you don’t understand? I have tested your advancedsystem settings and it works fine with any video that fits my available network bandwidth.
So based on your bandwidth (considering that was measured in the direction NAS to Vero you should be able to play this file http://jell.yfish.us/media/jellyfish-40-mbps-hd-hevc-10bit.mkv

@fzinken

Thanks for your time.

  • If my Vero 4K is directly connected (no PLC) to the router, in this case i don’t need advancedsettings.xml because i have the max bandwidth available. (no lag or stuttering)

This is my need :

  • Where my TV is located i need the PLC adapter.

If i consider my NAS is the server and i run “Iperf3 -S” on it
I have a bit rate of at least 60 Mbits/sec (sometimes it’s lower around 55Mb/sec)

https://img4.hostingpics.net/pics/433951lan.png after 5 min

“jellyfish-40-mbps-hd-hevc-10bit.mkv” is a small file with a demanding bit rate.
When I playback this file the player reads it fine.
if i pause the playback i can even see the extra cache loading up to 1/4 of the bar.

But i need more cache, for larger files with nearly the same bit rate or up to 55.7 Mb/s
Because when my network performance drops i will have extra cache and the playback will not interrupt.

Unfortunately:

I can’t add advancedsettings.xml without breaking my playback
the player opens the video and closes it instantly… no buffering gauge or else.
if i change the buffer mode to 0 it will play fine but i need a buffering for local files.

My question is : why i can’t use anymore advancedsettings.xml like a used to do before 17.5 update.
What am I doing wrong ?

You have yet to post a full set of logs from when you say advset is not working. Until then, we have no magic fix to offer since we don’t clearly see a problem.

Did you run iperf3 on the client with the -R option so to simulate that the server is sending?

1 Like

@fzinken

Hi again

From the start i now my LAN is quite slow but has enough bandwidth to handle video playback correctly.
I reinstalled Kodi.
Right now the issue is advancedsettings rather than the network performance
will provide a full log

iperf3 -c 192.1xx.x.xx -p 5201 -w 640k -t 120 -R

[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-120.00 sec 857 MBytes 59.9 Mbits/sec 72 sender
[ 4] 0.00-120.00 sec 856 MBytes 59.8 Mbits/sec receiver

I was able to solve this issue by creating a NFS share over SMB.
Now advancedsetting.xml allows OSMC to buffer enough to get extra cache for larger files when the network is slowing down.
For some reason advancedsetting.xml was not properly working with SMB share since my update to 17.5. (not possible to read / resume no matter which values were used)