Buffer issues after October Update

kodi nfs mount, but I think it isn’t the problem
For me it’s perhaps the remote protocol

  1. Sony remote with CEC library
  2. OSMC remote
  3. Kodi Android app Kore ou Yatse

Do you have more than one switch?

There is a risk with multiple unmanaged switches of getting a “broadcast storm” if the switches are incorrectly connected together. When this happens, the network will seem to freeze.

Hi Dillthedog
Yes I’ve, but I think it isn’t the problem. The network works allways, but sometime when i try to play forward or backward I’ve issues.
Before the oct update Kodi freeze (ssh restart mediacenter) now (only) sometime the image freeze, but i can go back to the menu and restart the movie.
Here I think it’s a buffer issues (and when I remember right I 've copy my cache settings from one of your threads)
With Kodi 17.5 and the new ffmpeg perhaps better cache settings are possible ??
And the second point I’ve not this issue (with the same movie) everytime, and I use different remote on my two box.
But there is the jungle.
Perhaps found in first time the best cache settings.
Merci
Michael

I thought it was at least worth mentioning the possibility of broadcast storms.

I doubt if increasing the readfactor higher than 6 will help - but it won’t do any harm, though it will probably cause Kodi to use all the network bandwidth in short bursts.

The memorysize is a little more difficult to recommend. The Kodi wiki continues to suggest that it will use RAM that is 3 times the number you specify. However, people have examined the actual code and this no longer seems to be correct. So you’ll need to experiment - but at least the Vero4K has more RAM than a Raspberry Pi, so you have more scope for experimentation.

I play a bit with cache settings and switch to

 <cache>
            <memorysize>191889408</memorysize>
            <buffermode>1</buffermode>
            <readfactor>6</readfactor>
    </cache>

when I understand right I use 186 MB
Play /for/back etc seems to works
I check with free -m and that give

osmc@wst10:~$ free -m
             total       used       free     shared    buffers     cached
Mem:          1789        424       1364         19         18        143
-/+ buffers/cache:        262       1526
Swap:            0          0          0
    osmc@wst10:~$ free -m
                 total       used       free     shared    buffers     cached
    Mem:          1789        623       1166         19         19        143
    -/+ buffers/cache:        460       1329
    Swap:            0          0          0
    osmc@wst10:~$ free -m
                 total       used       free     shared    buffers     cached
    Mem:          1789        624       1164         19         19        143
    -/+ buffers/cache:        461       1328
  1. is KODI with skin estuary
  2. is movie started and pause
  3. is movie played

Now I need some advice if it’s a good VERO4 settings
On my Vero4 box i run only KODI, MySql (MariaDB) Server and TV Backend run on the NAS.
Merci
Michael

That’s very interesting. (And meshes neatly with my last post here :slight_smile: )

It shows that the amount of used memory increases from 262 MB to 460/461 MB once you start to play. This confirms that the 3x RAM usage is no longer correct.

One user suggested:

<buffermode>1</buffermode>
<memorysize>400000000</memorysize>
<readfactor>30</readfactor>
</cache>

Is that recommendation based on anything concrete? There must come a point at which increasing the buffer further has no appreciable extra benefit.

Here’s the memory on my Vero4K with mediacenter running (and all Kodi defaults):

osmc@osmc:~$ free -m
             total       used       free     shared    buffers     cached
Mem:          1789        981        808         16        118        657
-/+ buffers/cache:        205       1584
Swap:            0          0          0

I’m only using 205 MB of core RAM to run OSMC. Even if the buffers and cache are left untouched, there’s still 808 MB doing nothing.

For now it’s works for me. But the play for/back problem is the most of time with recorded movies with publicity.
I test it in “real life” conditions and report back.
A+
Michael

No – but I do believe we should adjust advancedsettings.xml for Vero 4K, as we have more memory to play with. I’d like to get some sane values established and included in the next update.

I’d like to weigh as I recently had some issues with playing back a high bit rate file (nearing 90 Mbps) while other high bitrate files where playing fine. For me mounting the shares with fstab instead of nfs directly helped alleviate these issues. I’m using a buffer of about 190 MB with a read factor of 6, and my files are on a QNAP NAS.

In the past (a few months back) I kept having buffering issues which were the result of making the buffer too large. They went away when I lowered them.

1 Like

Thanks for the feedback.
Can you paste the full advancedsettings if you’ve made any other changes?

Sam

The only things of relevance in my advancedsettings.xml are

 <network>
	<buffermode>1</buffermode> 
	<memorysize>190000000</memorysize>
	<readfactor>4</readfactor>
</network>

I see I misremembered the read factor.

There’s also some path substitution so I didn’t have to change my original sources when changing to fstab.

Hi Pleomin,

As of kodi 17, the flag has been replaced with so your advancedsettings.xml should be:

<cache>
	<buffermode>1</buffermode> 
	<memorysize>190000000</memorysize>
	<readfactor>4</readfactor>
</cache>

Thanks Tom.

good to know

I’ve play with for/back (same cache settings) and now i’ve the issues image/movie freeze, but Kodi run all ways
here is the log https://paste.osmc.tv/owihefigom

free -m

>               total       used       free     shared    buffers     cached
> Mem:          1789        766       1022          8         22        195
> -/+ buffers/cache:        548       1240
> Swap:            0          0          0

Film Cent mille dollars au soleil time 15:25

I’ve been using the following settings since February, without issue:

<advancedsettings>
	<cache>
		<buffermode>1</buffermode>
		<memorysize>536870912</memorysize>
		<readfactor>20</readfactor>
		<curlclienttimeout>10</curlclienttimeout>
		<curllowspeedtime>10</curllowspeedtime>
	</cache>
</advancedsettings>

I figured using 512mb of cache would be fine, since the Vero has so much free memory available, and it’s been working great. When watching my own videos or streaming something from an add-on, my entire cache fills up rather quickly and I never experience any buffering, no matter the file size.

I was suffering from 4k files stuttering and audio drop outs after a few minutes. On bringing up the process info panel in Kodi (o key) - I could see that the player cache would end up a 0% full when the issues would occur.

I went for

<advancedsettings>
<cache>
	<buffermode>1</buffermode>
	<memorysize>256000000</memorysize>
	<readfactor>6</readfactor>
</cache>

Post that change i can play all my 4k files (including 60fps / HDR) without issue and the player cache stays at 100% full.

Thought i would share as more evidence for tweaking the defaults for Vero 4k :slight_smile:

Good man.

Thank you for your feedback. It will definitely help us improve things out of the box.

Hi
I try memory 256xxx with the same movie and my play back/forw stress test. It’s works.
But I cann’t send you the logs @sam_nazarko

osmc@wst11:~$ grab-logs -A
Logs successfully uploaded.
Logs available at https://paste.osmc.tv/<html>
osmc@wst11:~$ 

I think that i’ve see this message in the past but I don’t remember.
I wait for the solution to send the logs, then I try with a “fresh” movie recorded, but never played.
A+
Michael