20+ second delay to before music start playing

Now the shares are back as they should - but so is the delay when starting the track…

Well it slowly but truly points to issues with the NAS, but you might want to try either:
Could try the SMB access within Kodi (@darwindesign showed you how to)
Or you can try autofs mounts (use search function)

Now the shares are back as they should - but so is the delay when starting the track…

Well it slowly but truly points to issues with the NAS, but you might want to try either:
Could try the SMB access within Kodi (@darwindesign showed you how to)
Or you can try autofs mounts (use search function)

Yes, I have been thinking the same thing - that it might be the NAS. My DS414j must be at least 7 years old now - even if the disks have been replaced at need. I will try the other access methods first and if that diesnt work (dont exopect it to) i will have a look at the NAs, or maybe replace it.

I replaced my sources.xml with the info @darwindesign supplied and rebooted. The libraries loaded just fine, but the delay is still present.

ill try autofs mounts tomorrow - tonight I will run harddrive tests on my Synology - no idea how i can test file access on it…

When i set up the autofs - which of nfs and smb would be the preferred protocol?
I assume i should clean out the sources.xml and try to map sources again from scratch after autofs is runnig?

Well if you have nfs on the NAS than try that as it also would give another alternative to try.
My recommendation would be to remove your fstab entries and just use autofs to mount to the same folders (then you don’t need to change the sources.xml).

Just to complete the topic here is the howto

Thanks, ill report back when i tried it!

Just to add I have a DS416j and share via NFS with the source added in kodi. No 25 sec delay.

removed fstab and edited auto.nfs.shares but things dont work - to begin with - does this entry look correct?

/mnt/Movies_NAS 192.168.1.5:Media/Movies

As I understood the instructions, this entry will mount the folder Movies that is located on the share Media on server with ip 192.168.1.5. The Movies folder will be mounted as Movies_NAS.

also, dont i need to add my password and login to NAS anywhere when i use nfs? (I added /- /etc/auto.nfs.shares --timeout 15 browse to auto.master file)

Here is an example, how I mount the music folder of my Syno (DS214se) in /etc/fstab:

synologyds214se.fritz.box:/volume1/music /mnt/music   nfs x-systemd.automount,noauto   0   0

No NFS is not using username/password, access is controlled by IP Address Range that you would have to allow access on the Server.

This looks right, did you also configure auto.master?

If you have auto.master also configured and you given access rights on the server. I would follow the troubleshooting steps in the how to

You need the leading /, and it has to match how it’s shared on the NAS. If it’s shared as /Media/Movies then:

/mnt/Movies_NAS 192.168.1.5:/Media/Movies

would be correct. Also, linux is case sensitive, so make sure cases match.

NFS normally does not require authentication.

Actually looking at this comment and also some of the other topics.
One more test you could do. You seemed to not have problems playing the file from local storage (emmc) but I am not sure if in that case you played via Library or just Files. So recommended test add the local file to Library and try to play via Library and see if issue happens or not.

I wil move a cpl of files to local and try them after adding to library.
Menawhile, here is a bit of a log. it continues the same way for quite a while.

osmc@osmc:/mnt$ sudo systemctl stop autofs
osmc@osmc:/mnt$ sudo automount -f -v -d
Starting automounter version 5.1.2, master map /etc/auto.master
using kernel protocol version 5.02
lookup_nss_read_master: reading master file /etc/auto.master
do_init: parse(sun): init gathered global options: (null)
lookup_read_master: lookup(file): read entry +dir:/etc/auto.master.d
lookup_nss_read_master: reading master dir /etc/auto.master.d
lookup(dir): dir map /etc/auto.master.d missing or not readable
lookup(file): failed to read included master map dir:/etc/auto.master.d
lookup_read_master: lookup(file): read entry +auto.master
lookup_nss_read_master: reading master files auto.master
do_init: parse(sun): init gathered global options: (null)
lookup(file): failed to read included master map auto.master
lookup_read_master: lookup(file): read entry /-
master_do_mount: mounting /-
automount_path_to_fifo: fifo name /var/run/autofs.fifo–
lookup_nss_read_map: reading map file /etc/auto.nfs.shares
do_init: parse(sun): init gathered global options: (null)
mounted direct on /mnt/Music_NAS with timeout 15, freq 4 seconds
do_mount_autofs_direct: mounted trigger /mnt/Music_NAS
mounted direct on /mnt/New_NAS with timeout 15, freq 4 seconds
do_mount_autofs_direct: mounted trigger /mnt/New_NAS
mounted direct on /mnt/MusicVideos_NAS with timeout 15, freq 4 seconds
do_mount_autofs_direct: mounted trigger /mnt/MusicVideos_NAS
mounted direct on /mnt/TV_NAS with timeout 15, freq 4 seconds
do_mount_autofs_direct: mounted trigger /mnt/TV_NAS
mounted direct on /mnt/Vero_Home_NAS with timeout 15, freq 4 seconds
do_mount_autofs_direct: mounted trigger /mnt/Vero_Home_NAS
mounted direct on /mnt/Movies_NAS with timeout 15, freq 4 seconds
do_mount_autofs_direct: mounted trigger /mnt/Movies_NAS
st_ready: st_ready(): state = 0 path /-
st_expire: state 1 path /-
expire_proc: exp_proc = 4104123472 path /-
expire_cleanup: got thid 4104123472 path /- stat 0
expire_cleanup: sigchld: exp 4104123472 finished, switching from 2 to 1
st_ready: st_ready(): state = 2 path /-
st_expire: state 1 path /-
expire_proc: exp_proc = 4104123472 path /-
expire_cleanup: got thid 4104123472 path /- stat 0
expire_cleanup: sigchld: exp 4104123472 finished, switching from 2 to 1
st_ready: st_ready(): state = 2 path /-
st_expire: state 1 path /-

What does showmount -e 192.168.1.5 give you?
And what do you have in auto.master?

auto.master contains - excpet the lines commented out

+dir:/etc/auto.master.d

+auto.master
/- /etc/auto.nfs.shares --timeout 15 browse

and showmount -e 192.168.1.5

osmc@osmc:~$ showmount -e 192.168.1.5
Export list for 192.168.1.5:
/volume1/homes 192.168.1.21
/volume2/Music 192.168.1.21
/volume1/Media2 192.168.1.21
/volume2/Media 192.168.1.21

added the two albums i knew were making trouble to an USB drive and scanned into my Music library. No problem playing them.

I assume 192.168.1.21 is the IP of your Vero.
You then would need to use /volume2/Media

yes 192.168.1.21 is the Vero, the etc/auto.nfs.shares file looks like this:

/mnt/Movies_NAS 192.168.1.5:/Volume2/Media/Movies
/mnt/TV_NAS 192.168.1.5:/Volume2/Media/TV
/mnt/New_NAS 192.168.1.5:/Volume1/Media2/__New
/mnt/MusicVideos_NAS 192.168.1.5:/Volume1/Media2/Music\ Videos
/mnt/Music_NAS 192.168.1.5:/Volume2/Music
/mnt/Vero_Home_NAS 192.168.1.5:/Volume1/homes/MediaCenter

if i do ls for the mnt folder i get:

Files_NAS Media_NAS MusicVideos_NAS New_NAS Vero_Home_NAS
Home_NAS Movies_NAS Music_NAS TV_NAS

Files_NAS and Media_NAS is not in auto.nfs.shares, and not in sources.xml

Remove the Movies part also Volume has to be volume