2016.01-01-HDD not actually installing to HDD

Finally got some time today to get around upgrading my CB2/Kodi hodge podge to OSMC. I tried installing the January update but it doesn’t seem to install to HDD (just USB), gave it a second shot and no go as well. I then installed the 2015.12-4-HDD which was all good until I ran the January update and got the frowny face reported in another thread.

Any chance the 2016.01-01-HDD isn’t correct? It’d be nice to go straight to this as the release notes look like it fixes the update issue.

Thanks again for all your work on this, love this project!

Cheers

One user reports that the images were mixed up for him. Try re-downloading – I haven’t verified this myself.

You will get a prompt to remove the USB to proceed with HDD installation

Sam

Yep, tried a second time to make sure I selected the right option, just tried a third time as well, same thing, straight to the OSMC ‘formatting device’ screen.

OSMC_TGT_appletv_20160130-HDD.img.gz is the file in my profile dir. No remove USB/restart instruction as it did when I tried the December HDD install.

Log file: http://pastebin.com/9p93ZgUF

Hrm… when I go to install it goes to the yellow progress bar.

After a long time, the progress bar completes and the following message is displayed:

Install failed: tar: corrupted data

I’ve tried this twice, with no luck. Also, I’ve used this USB stick for older OSMC installs without issue.

Where? I’m not aware of a yellow progress bar, but I suspect it depends on which OS and any theme running on your PC / Mac.

The hard disk images are hand-built at the moment from USB ones. You can always download a USB installer and edit com.apple.Boot.plist post-image and add ‘atvinst’. This will instruct the installer to write to the hard disk. This is the only change I have made from the automated build of the USB based installer, but it’s possible the upload was corrupted or one of the mirrors is.

Sam

Sounds good! Though I have no idea how to do that! :slightly_smiling: I know how to edit it, just need to know what element/string I need to update?

Just add atvinst to the list of kernel arguments

I had the same issue with january installer!
I decided to do a reinstall after the update problem with december image.
Using the january installer there is not the advice to remove the thumb drive and reboot, it goes straight to installation.
Then it’s impossible to remove the thumb drive because I always get the sad face.
Also if I connect the external hd before boting I get a kernel panic.

Thank you

Small update: I managed to get atvinst added and was able to proceed with normal HDD install process. Though now it is hanging at then end of ‘Installing files’ (this was also happening with the USB install). I’m going to use a December USB install version to SSH in and grab any log files from the HDD, I just need to know where to look for them?

To test this, yesterday I did both HDD and USB installs using the Jan 2016 image, using the normal installer via OSX.

Everything worked as expected. No frown face. Small prompt telling me to remove UBS stick, and power cycle the device etc.
Played 1080P videos over networked NFS share, and vimeo streams, with my Bluetooth keyboard, and apple remote, without issues.

I’m using a ATV1 with the oem harddrive.
The only thing I can think that would be different is the USB stick used, or the OS the installer is run on.

@KickMeInTheJunk Considering that you haven’t successfully installled OSMC before, I’d try a different stick. The stick used is a common problem for some. In your specific case it may be issue.

For others who have had working systems, there is something else going on.

The logs are dumped in root of the install stick.

All went well for me on my ATV1 160GB
I used the OSMC_TGT_appletv_20160130-HDD.img from the windows(7) installer (Poundshop FNKTech Generic USB Cardreader with a 2GB MicroSD card)

I’ve had the same problem with no advice to remove the USB stick and reboot - my experience too is that it goes straight to installing files.

I’ve tried multiple times with the same results.

Also, I’ve been using the same USB stick as I’ve used for the December builds. As I had trouble with the January build, I’ve reverted to the December build for the time being.

So the question becomes, what is different in the systems that make a small number of them not work ?

Are you using a Non OEM internal drive ? If so, what is it ? how is it connected ?
Are you using a USB Hub when installing ?
Are you doing anything that would be different than simply a stick directly in the ATV with original internal HDD configuration ?

@vanfog What OS are you using to create the USB stick ? What OSes do you have access to ?

I ask, because there are no usable logs at that stage.
Getting some useful log output is possible but requires an OS that will allow someone to edit the com.apple.boot.plist on the HFS partition before you boot the installer stick.

Without that log, this problem can’t be solved, since we have no way of seeing what is causing the glitch of the install continuing, without pausing to allow removal of the stick, for some users.

@Spinner, I have an access to Windows, Mac OS and Linux. What should I do to get the logs? I can’t install January build with any USB-stick and get “Installing files” stuck on 100% and also my Apple TV after reboot stays on previous OSMC installation.

@Lamoboy Are you trying an HDD install ? Does it bypass/skip the part where the small prompt appears on the terminal output which asks to remove the stick ?

Yes

There was no such prompt in January build like it was in December one.

Ok. Good. :slightly_smiling:
Now to find what is making your systems bypass that prompt…

The basic procedure will be, to edit the plist on th ATV with a flag that includes the IP of your local network machine, which has netcat server running on it. Once the netcat connection is established you run the install from command line, and view or save the output.

First, I’ll confirm with Sam if the commands have changed.

EDIT:
Everyone who is not getting the “remove usb stick” prompt, please supply the following info:
Are you using a Non OEM internal drive ? If so, what is it ? How is it connected ?
Are you using a USB Hub when installing ?
Are you doing anything that would be different than simply a stick directly in the ATV with original internal HDD configuration ?

Stay tuned.

I had exactly the same experience.
I also used the same stick for december and january insaller.
December shows the prompt for removing stick while january doesn’t.
I’m using osx to install on the stick.

Hello Spinner

Until yesterday the Image OSMC_TGT_appletv_20160130-HDD.img.gz with creation date 01.30.2016 was active, which didn’t contain the query to remove the USB stick. As of 01/31/2016 there is an altered image, the name has remained the same, only the date of creation had changed.

The Image has the following MD5 hash value: a5809099ba8f19836e83abff56eeccf6.

This can be a fresh installation now again perform.