2016.02-4 CEC partial fail on input change to OSMC

Thanks.

wget --no-check-certificate "https://www.dropbox.com/s/xyk0m5v741c1kjj/rbp2-libcec-osmc-nomk.deb?dl=0" -O libcec.deb
sudo dpkg -i libcec.deb
sudo reboot

This one does not work. Partial loss.

1 Like

I don’t understand what you mean by ‘partial loss’. If you want to wget the Deb directly, you will need to change dl=1 to avoid the HTML download page, otherwise SCP the Deb over.

dl=1 to avoid the HTML download page

Got it.

With “partial loss” I mean that CEC control is still available and working ie; I can control OSMC via my Panasonic remote but the volume control of the Panasonic surround system is lost.

So I can’t control the volume of the surround system anymore - it stays stuck on the current volume and volume control reverts to the TV itself. The only way to get the surround system volume control back is to re enable it via the Viera Tools button. Changing sources loses surround system volume control again.

This means that it is @gda’s patch introducing this behaviour. Please replicate the issue from a clean boot with debug logging enabled from the start and post logs on our Pastebin

The patch does resolve a lot of CEC issues and for some users CEC does not work without it, so I am keen to keep it in for Sunday’s update

It’s been pushed since Saturday and I haven’t seen any reports of significant regressions so I am inclined to keep this in for now and provide this Dropbox binary as a fallback to those affected

Understood - unfortunate. Logs below (fresh reboot for both):

http://paste.osmc.io/kawopilove
http://paste.osmc.io/nupoxevoqo (libCEC logging enabled)

Hopefully this can be fixed.

Thanks again Sam.

Would you like me to try your other builds @sam_nazarko?

Kids and wife not happy with this change at all…

Sorry to hear that

In the interim, you can always use the CEC build I posted which you said didn’t have any issues until we work out what’s up.

No probs, at least it’s easily fixed with the interim build. Thanks - all good.

Looks like I’m having a similar issue with a Vizio M601d-A3R connected through an Onkyo TX-SR607. I took an upgrade to OSMC on my RPi2 on 3/27/16 and CEC stopped working. I assumed there would be a fix out shortly, so I just used Yatse as a remote for the week. The upgrade yesterday 4/3/16 broke Yatse - no arrow functionality but I could still run volume and reboot it from Yatse. I searched for similar issues and found this thread.

The fix from the second post above:

fixed the CEC - which is good - but Yatse is still busted. Which is a real issue since I haven’t ever figured out how to get to the options menu from my Vizio remote/CEC.

Thoughts?

wget --no-check-certificate "https://www.dropbox.com/s/y6weou58vh77win/rbp2-libcec-osmc.deb?    dl=1" -O libcec.deb
sudo dpkg -i libcec.deb
sudo reboot

Hi @sam_nazarko.

Can I run this script to fix the above “issue” again?

The same issue is present on the latest July 31 release. Once the source is selected away from the TV to OSMC the surround system drops the speakers back to the TV. I then need to reset VieraLink to get the surround speakers back for anything.

Thanks in advance.

Answered via the PM that you sent me.

Thanks Sam.

Hopefully they can do something over at GitHub about this.

Improvements to CEC can be found in [TESTING] Kodi 17 (Krypton) Beta Builds for all platforms

I’ve sent you a private message about this giving some detail, as I remember we had some discussions about CEC.

Keen to hear how you (and others if they are experiencing a problem) get on.

Sam

Installed a freshJarvis install then restored a backup of my previous system so it didn’t have the CEC patch you provided.

Had issues with a continuous sad face bootloop. Got around this by renaming .kodi folder. Not sure what the issue is there…? Could it be because of me using Confluence skin?

My CEC seems to still be having the same issue.

HI,

After i updated to 2016-9-1 have several CEC issues with a Samsung Tv (Anynet+) and a soundbar by Yamaha.
Before the update everything was working flawlessly.

I notice CEC is very slow to connect which means that i’am not able to use my TV remote for 5 minutes.
Then when i switch source from HDMI 1 to TV it looks like CEC won’t switch because i still have acess to Kodi CEC menu when on TV source… i also have sound issues because the CEC-ARC is not displayed on TV.
When i go back to Kodi on HDMI 1 the amp does not show Kodi CEC menu anymore.

Tv and Amp starts and shutdown correctly via CEC

any ideas to get this working ?

regards

Not Ok,

i tried to factory restore my TV (great !!!) but no change so far
and unplug the TV to get rid of residual memory but no luck so far

I triggered “connected to HDMI device” by changing Physical address… but it’s a no go
Btw i wonder why this option is not seen in the menu otherwise…
any help here ?

.

Krypton Beta 5 and libCEC 4.0.0 has fixed my issue.

Jarvis obviously requires your patch.

Thanks Sam.