2018.03-2 update has broken my passthrough sound

Noticed the 03-2 update was available and installed. Started one of my 4K files and absolutely no sound. Tried another one, it was ok, re-booted, find issues with sometimes there is no sound, sometimes there is. In one case, a file with a 7.1 Dolby Atmos track is silent, and bizarrely, my AVR reports that it is receiving a 3/2/.0 file with a -31dB offset.

Folks, I appreciate that OSMC/Vero 4K is operating at the boundaries, but at the moment, the QA on builds seems way too flaky. I’ll try to come back with a log later.

Did you have problems with the February update?
We’ve made all of the audio changes that we have planned publicly available on the forums so far.

Re QA: are there other issues you are experiencing? The forum seems relatively quiet post-update so it would be good to see if there are wider issues.


No, never had this problem before. Same source mkv’s, no changes in configuration. I’m unavailable for the next hour or so, will come back later and try to find a pattern, e.g. is it an Atmos issue.

Log: https://paste.osmc.tv/etoyefemiv

Feature of this example: first title cued for playback is fine. I stopped it after a few seconds then cued another 4K title, and this time - silence.

Beginning to look like an Atmos issue. Just tried an episode of GoT series 7 and had no sound.

Spoke too soon, DTS-HRA is broken as well. Never had HD audio passthrough issues before. Looks like I need to revert to an older version of OSMC.

Same here. Just applied the march update, now no Atmos on any rips. Previously ok.

Back on 2018.02-1 and all is well. I know this build doesn’t preserve channel mapping correctly for 5.1 PCM sources, but at least I have sound every time.

I also lost my atmos sound (And possible more) and the rc6 remote with the update that was releases in the last couple of days.
I was on the february update before.

How to revert back to 2018.02-1?

Apologies, I think the Feb build fixed the PCM issue.

I use the PC installer to format a USB stick and then plug it in to the Vero. In my case I have to select the option of using an SD card when using the Windows installer, as the radio buttons in the installer don’t work. But after I select SD card, my USB stick then shows as a destination drive for installing OSMC to the USB stick.

I believe you can back up your config first, I don’t worry about that as I keep my sources.xml and advancedsettings.xml files centrally, and my library is held centrally too.

Here to confirm. Atmos is no longer working. DTS:X works and other formats but Atmos is gone. And IR remote is not working as well.

Edit: tried another Atmos movie and sound was working. Not sure why.

I found the problem to be a bit random, I might start playback and have no sound, switch to another title and then back, and then the sound was working again. But it was not just an Atmos issue for me.

It seems the March-2 release is very broken, best for it to be pulled?

1 Like

Several more of us having the same issue (see last 3 posts by Clockkent, me and Wuschel_Wushel here: No Audio with DTS-HD-HRA Movies - #46 by Bisonator) and it also affects DTS-HD MA

There were some attempts to fix problems with low-end Denon AVRs. I’ve removed these fixes now. You should be able to update and the problem should be resolved. It could take an hour for this update to reach your mirror.

With Denon receivers, it looks like the issue is caused by a lack of timing between the double reset on HDMITX_DWC_AUD_SPDIF. So while there may be an opportunity to resolve lower end Denon units in the future, we have to revert these changes until we have further testing.

Passthrough audio was working again with the latest update!

Then I switched to the nebula skin and I got again no passthrough … I an slowly getting desperate! Can it be that multiple skins settings influence each other ???:scream:

In addition the movie scraper stopped after a few movies and now I can only add movies manually one by one. This is all not doing what I expect … :fearful:

Hi Sam, installed the rollback and no change for me either, HD audio, both Atmos and DTS is very hit and miss, mostly miss.

Please post uname -a so we can actually see if your device is up to date.

Won’t be related at all. Start a forum post with debug logs if you have issues, and let us know which movie scraper you are using.


Is this what you are looking for Sam?

Linux JasonVero4K 3.14.29-66-osmc #1 SMP Fri Mar 16 21:43:36 UTC 2018 aarch64 GNU/Linux