23.98Hz not available?

I have my settings set to let the framerate adjust to the video source.
I have been noticing a “twitch” every 6-7 seconds or so since the last release I think. Haven’t got to investigating until today after the feb. update.
When I go to the video settings and cycle through the available frame rates I notice that the 23.98Hz mode is not available to choose anymore. And most my videos are 23.976, so that’s why I get the twitch I think.
Any idea why the 23.98Hz mode is absent?

If it was related to 24hz vs 23.976hz you would get a slight jump approximately every 42 seconds, so it’s unlikely to be due to that.

Think I have the same problem. I am stuck with november release due to stuttering playback and no 23.97 Hz option.

Same here, running v. 2016.01-1

No one here provides any logs demonstrating a problem so, no one here will receive any relevant support…

Here are my logs:


Thanks in advance.

I will investigate this issue



Do you guys see the frame skip in CodecInfo?

I get frameskips logged in codecinfo, but not the same time I get the visual “jump” which occurs about every 8-9 seconds or so.

Any news on this issue?

Regarding the skipping issue, did you try this: MMAL Skipped frame or judder every few seconds - #15 by kartana

Edit: this probably only works for the RPi. I’m sorry for ignoring the Vero tag in this thread! :unamused:


I haven’t got the faintest clue on how to go about that - besides, when the 23,98 fps setting was introduced to the Vero a good while back, it was a fairly big thing, and now it has suddenly disappeared without anyone being able to tell us why…

Best regards

My “skips” seem to have disappeared when I removed the -0.145 second sound delay after I bought a new reciever and changed from optical to HDMI sound. However, I would like the 23.98Hz option back. Why was it removed?

I double checked. The 23.98Hz setting hasn’t been removed.

There was a change to how modes are displayed and detected. You would need to post your EDID (a search will explain how to do that). It’s possible your TV / AVR is not advertising this mode as available.

You don’t need to change the Display mode for 23.976Hz refresh rate. Just enable ‘Adjust refresh rate’ and Kodi will change the refresh rate when playback begins


I hope this EDID info is correct: http://paste.osmc.io/sedoyipipe.hs

Hi Sam!

I’m a happy owner to both the Vero1 and now also the Vero 2.

I have a high quality Epson projector in my cinema setup which supports both 23.976 Hz and 24 Hz ( and 50/60Hz)

I have this slight stutter every 42 sec or so…

Since november or december 2015 Vero does not adjust correctly to 23.976. Instead it plays my movies in 24 Hz. Same with Vero 2…

I’m truly happy with both Vero 1 and Vero 2 but this is of course disturbing. I have spent many, many hours of course trying all possible settings in OSMC…

Is the problem in Kodi itself? Licensing rights or what? I did choose to not not open a new thread in the Vero 2 section.

Keep up your good work.

//Johan, Sweden.

Hi Johan

There is no licensing restriction preventing us from using 23.976Hz. The Vero 1 and Vero 2 should be able to do this. I watch TV with my Vero 2 regularly with 23.976 content. There may have been a regression on Vero 1, but when I checked in March, the setting was still there, and still functional. I’ll revisit this however, as I need to rebase the iMX6 code for Kodi Krypton.

  • Make sure adjust refresh rate is on
  • Make sure that your projector is ‘advertising’ support for 23.976Hz. On a Vero 2, you can test this with:
  • Make sure you are on the latest version of OSMC. Some users had some stuttering in May, but this was not related to 23.976Hz.
cat /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap

You should see at least one listing for 24Hz.




Thanks for your nice answer!

The last time I was able to output true 23,976fps, not 24fps, was with the vero 1 and the osmc 2015.11-2 (kodi 15.2 compiled nov 28 2015)

Of course, I have adjust refresh rate on (start/stop) :slight_smile: tested them all… And tried with every new osmc release last months.

I have this infamous glitch every 41 seconds. I suspect you have heard about this before…

Maybe you are not able to reproduce this on your 24fps TV. Maybe your TV has a smooth motion function that “hides” the 41 sec glitch for you. I am just brainstorming…

I attached a photo on my Epson info(menu) with Vero 1 nov 15 release. This was the last time I had perfect playback. Notice the 23.976.

Today I received the Vero 2 (thanks!) and the problem is still there. I have the latest software. 24fps output only…

I have Googled this but I am not that super technical… I read something about the amlogic error bla bla bla or that it was not Kodis fault :slight_smile: and you mention the imx6 code :slight_smile:

Hope this gave you any clues? Any ideas? I want to help you :slight_smile: Johan

Hi Johan

I will look in to the Vero 1 issue, because it’s possible there was a regression with Jarvis. We will be rebasing for Krypton shortly so I will take a closer look then.

You definitely should not have this problem on the Vero 2 though. AMLogic can do 23.976 now (with a pixel clock adjustment).

  • Can you check you are watching at 1080p on the Vero 2? (I am not sure if above screenshot is from V1 or V2)
  • Can you run the command suggested above so I can see what modes your TV advertises for support?

I am using an Optoma projector with an AVR and do not notice the 41 second issue on the Vero 2. My device is susceptible to it (no smoothing). I haven’t watched something on the Vero 1 recently, so I can believe that there may be a regression there, but the Vero 2 should be OK.

Where do you see this?


I now have spent 3 hours of watching all kinds of Movies, mostly bluray mkv’s 10-45 GB filesize and I even had a stopwatch and sadly… well with a 41-42 sec interval the glitch is there with the Vero 2.

You wrote “TV” but I have the Vero2 directly into a Epson projecor over HDMI. The Vero 2 seems to output 24fps and not 23,976fps. I even updated from osmc july to august, no difference. The Epson reports 24fps anyway (is that what is called EDID?)

Yes, I’m at 1080p.

I have no experience in SSH but if you want me to I can read the wiki I suppose if you still want me to run that command you asked me too?

I also could try to give you some logs (no experience), but I’m not sure if my Equipment and Environment is the problem here.

The Pictures in my previous post above, as I wrote, is with the Vero1 osmc nov-15.

Here are Pictures with my Vero 2. Epson reports 24.00 fps and 1080p