25-30 seconds to play video via nfs (recent)

Recently it has taken almost exactly 25-30 seconds to play any video via nfs (hosted on Mac on LAN). This is a new issue, possibly since last update. Ethernet connection. Checked iperf3 and found no speed problems either direction.

logs confirm for each play attempt there is exactly that lag between “OnPlayMedia nfs” and the first (CPlayerCoreFactory) GetPlayers. (from attempt to make sense of the debug logs).

unfortunately that’s as far as I can get with that. possible some issue reading settings files (CSSettingsManager). Any ideas?

Here are 3 debug logs in order:


I tried disabling what i thought might be problem plugins from the first 2 logs (googledrive and then lazytv). However, last log shows same problem.

Videos attempted in each: 3.10.To.Yuma and 3.Idiots. In last log, also “7 Khoon Maaf” with same problem.

  1. You are not on the latest version of OSMC. I suggest you search for Updates again and install latest verion.
  2. Remove your customized cache mode as the default should be sufficient
  3. If the latest update doesn’t solve the issue try to play the file from USB to see if related only to NFS

thank you. tried steps 1 & 2, same result. new log:

will try USB tomorrow.

Off topic, but you might want to review your advancedsettings.xml file a bit. On a quick glance I noticed you had <displayremotecodes> which was only used on an actual XBOX and I’ve seen setting <recentlyaddeditems> to a large number like you have cause problems. I also don’t think <moviesetextraart> is valid anymore.

As for the problem at hand I would try a system mount.

And did that… and the problem persists. Even playing tiny .mp4 video files (<200MB)
… again, what I notice is CSSettingsManager
and again will mention, this is a fairly new issue, maybe since last update.

… but the good news is – as it’s not a network problem –
I don’t have to figure out what that means, let alone how to do that. :slight_smile:

done, thanks for the tips. (have obv. had that this xmbc thing quite a while.)

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

Thanks, with that hint, I figured out the culprit without quite having to do this. Instead, I mv’d the .kodi/temp/ directory. Because the logs were showing:

2022-11-02 09:34:27.279 T:2773    ERROR <general>: GetDirectory - Unhandled exception
2022-11-02 09:34:27.279 T:2773    ERROR <general>: GetDirectory - Error getting /home/osmc/.kodi/temp/
2022-11-02 09:34:27.279 T:2773    ERROR <general>: GetDirectory - Error getting special://temp/

That solved this problem. Inside that temp folder was a 1.4 GB OSMCBACKUP file, which should have been relocated to the USB flash drive, but hadn’t been. Which means there’s a different issue here…