3 video/audio problems, factory reset?

I have currently the following audio/ video problems with my vero:

slow video playback and audio out of sync when playing small 100-800 mb files, (1080p/4k remux movie files plays fine)

low volume when streaming through my wifes thai tv addon. ( worked fine before )

barely heard audio on episode 3-4 on series x, episode 1-2 plays fine. ( ep 3-4 also plays fine on on mac/streaming from nas to phone )

I just thought I should do a factory reset and hopefully some of the above problems will go away.

How do I do this the easiest way?

/Challe

Check some settings you find at

GUI Settings->Player->Video

There activateAdjust Display Refresh Rate” and deactivateSync Playback to Display”. The latter prevents audio pass-through modes in general.

Upload full logs for us to check your settings.

thanks but that did not help, I also get a sad face when i try to delete a profile so I think a factory reset is my best bet since I have these four separate problems…

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

sudo systemctl stop mediacenter 
mv /home/osmc/.kodi /home/osmc/kodi.bak
sudo systemctl start mediacenter

If need you can restore:

sudo systemctl stop mediacenter
mv /home/osmc/kodi.bak /home/osmc/.kodi
sudo systemctl start mediacenter

thanks, I need to ssh login first right?

Yes, these are command line commands.

1 Like

ok, a fresh installation fixed the audio problems, but the vero still has problems playing small files 50-300 mb, they works fine on other devices and they worked before on vero too, they are speed up and out of sync.

Did you enable Adjust Refresh Rate after the fresh installation?

Regarding your video issue, check some settings you find at

GUI Settings->Player->Video

There activateAdjust Display Refresh Rate” and deactivateSync Playback to Display”. The latter prevents audio pass-through modes in general.

I tried that at the last installation, not this one, but I doubt it will have an effect, I also don’t like this setting since every time i start a video I have to wait 3-5 seconds for my projector to readjust the picture. The other setting was already deactivated. I also tried to play the same file on the kodi pc version, no problem there too.

This setting needs to be enabled for smooth playback.

well I´ve never had to enable this setting before but I will try again tomorrow and report back.

enabling adjust display refresh rate did not help

It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/.

You can also create the mediainfo-output of the affected media file on the OSMC device:

  1. login via SSH, user osmc, password osmc
  2. if not already installed: sudo apt-get update && sudo apt-get install mediainfo
  3. cdto the directory containing the video/audio material in question
  4. since mediainfoonly needs to read the header information of the file data, copy the first 4 Mbytes of the media file to a new file:
    dd if="<media file>" of=purgeme.bin bs=1024 count=4096
  5. upload the decoded media information using
    mediainfo purgeme.bin|paste-log
  6. publish the returned URL here in this topic
  7. remove the created media file snippet
    rm purgeme.bin

Thx for your help.

thanks I think I will also try to get the file unto osmc somehow, so I can rule out some setting on the nas that is causing trouble.

oh just great, now the sound problems are back again, all I did was restart the vero, I think there may some hardware faults in my vero, how can I replace it??

You can open an RMA by contacting support if you believe that there are faults, but this is unlikely and we would recommend uploading some logs first.

ok, I did another reset of kodi, sound is working now again, I will keep my hands of the sound settings. Hopefully the sound will stay stable.

Please turn on debug logging, reboot the Vero twice, play one of those files that you are having issues with long enough for the issue to manifest, stop the file, go to MyOSMC and upload logs making sure the “all configs and logs” option is checked, and then post the address given in this thread.

Even better would be to also gather media info as asked for above in addition to the logs. We can’t help you without enough information to assess where the fault is occuring.

2 Likes

https://paste.osmc.tv/ozeyaxazux

here you go: I played a file from the OSMC music folder (but its actually a video file)
the file played the same as the ones from the NAS, stuttered and audio out of sync.

I see a few problems:

You did not have Adjust Refresh Rate set to On Start/stop when you did the test. You have the GUI set to 1080 59fps, but the file you are playing is 25fps, so that will cause issues.

The other thing that I noticed is:

2019-11-14 12:58:58.568 T:3613651680    INFO: ffmpeg[D763F2E0]:     Stream #0:1[0x1100]: Audio: ac3 (AC-3 / 0x332D4341), 0 channels

It doesn’t look right to me, 0 channels.

Try again with either the GUI set to 25fps, or better turn on Adjust Refresh Rate.