3D BD ISO video freezing

I am having a few issues with playing a couple of MakeMKV backed up 3D Blu-ray iso files on my Vero 4k+.
Specifically with Wreck it Ralph 3D video freezes during the opening sequence, and with Corailne 3D video freezes about halfway through the movie. In both cases audio continues to play, and the GUI is still responsive.

Opening the same ISO in MakeMKV and extracting the main movie as an MKV produces a video file which plays perfectly.

I also have frequent issues with other files with the GUI locking up and requiring a reboot via SSH.

Is there a reason for this?

I have only recently purchased the Vero for playing back 3D Blu-ray movies and have backed up to ISO to fully preserve all content and in the hope the Blu-ray menus will be fully supported in a future hardware or software version but am starting to think that this is not worth the hassle.

Incidentally the BD menu in Coraline 3D does work, but when I select to play the 3D version of the movie (both versions are on the same disc) it reports that my system is not 3D capable.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Log file here.

The video freezes at the same point every time I play the iso.
In this case I was playing in 2D mode.

The video locks up during the first scene, I left it for 10 seconds or so after the video froze.

I can’t see anything obvious in the logs myself, the playback entries all seem to be similar before and after the video froze.

2023-02-02 17:11:49.423 T:3115 DEBUG : CVideoPlayer::CheckContinuity - resync backward :1, prev:54762666.333333, curr:31999.666667, diff:-54730666.666667

2023-02-02 17:12:25.038 T:3115 DEBUG : CVideoPlayer::CheckContinuity - resync backward :1, prev:54762666.333333, curr:42463999.666667, diff:-12298666.66666

Try and change Adjust display refresh rate: On start / stop to Always.

Do you get this with other titles?
Are only 3D titles affected?


No change with that setting unfortunately.

I’m only really using the Vero for 3D Blu-rays, but have only noticed the freezing issue with these two so far.

I’ve tried playing them from both a local USB drive, and from my NAS, with the same result.and video freezing at the same point every time they are played, whether in 3D or 2D.

FYI, the two problem ISOs play fine in Kodi 19.3 (or 20) on my Chromecast with Google TV, and in MrMC 3.9-12 on my Apple TV 4K 2022.
I can see a stutter/flash at the point where the video freezes in OSMC.

I’m still having a lot of issues with ISO files freezing. I had another two today with frozen video soon after starting. The last logs I posted didn’t seem to show anything, is there a different log setting I should be using to capture the video freezing, or anything else you can suggest?

Are only 3D ISOs affected?

I purchased the Vero to play 3D ISO so that’s mostly all i use it for. I have played a few 2D ISOs and plenty of other videos without this issues.

Ok, that’s good to know. I need some more info. Can you activate component logging for the Video and A/V timining components? Then reboot the Vero and reproduce that issue again. You can find those settings in Settings → System Settings → Logging. Thanks!

Here you go.


This is playing back Wreck it Ralph 3D ISO, in 2D mode on my TV. The same problem happens in 3D mode on my projector.

The video freezes from 1:07 and nothing I do will display any other image beyond this , either skipping chapters (freeze frame), or resuming beyond this point (black screen with OSMC logo).


From what I can see in the log is, that everything’s ok for the first 46 seconds and then suddenly the iso is closed.

2023-02-13 20:26:19.822 T:3043    DEBUG <general>: CNFSFile::Close closing file USBDisk1/media/3D Movies/Wreck-It Ralph 3D (2012)/Wreck-It Ralph 3D (2012).3d.iso

and then it’s reopened:

2023-02-13 20:26:19.828 T:3043    DEBUG <general>: CNFSFile::Open - opened USBDisk1/media/3D Movies/Wreck-It Ralph 3D (2012)/Wreck-It Ralph 3D (2012).3d.iso

and then playback is going crazy:

2023-02-13 20:26:19.956 T:3043    DEBUG <general>: CVideoPlayer::CheckContinuity - resync backward :1, prev:54762666.333333, curr:0.000000, diff:-54762666.333333

Just to verify: you’ve mentioned, that you can reproduce it also when playing locally from your USB drive, right? Does it happen at the same time? If yes, then it’s definitely not a network issue.

You said, you can reproduce it with other 3D ISOs, too. Can you name them? Maybe I’ve the same BD here and then I can try to reproduce it.

Yes I have the same issue when testing with a locally connected USB drive at the same exact point.
The Other ISOs I have had this with so far are Coraline 3D (half way through the movie) and The Force Awakens 3D (opening space sequence)

Bad luck :frowning: . The force awakens only in 2D here :slight_smile: … but I have an idea.

How is the USB drive formatted?

I can reproduce that issue. It seems to be a regression. Seamless branching seems to be broken. I’ll take a look.

That’s great news
With my limited knowledge of the structure of BD I wondered if it was something like that.

Let me know when you have something which needs to be tested.

Just FYI: I’ve fixed it, hopefully :slight_smile: . The fix will be part of the next build.

1 Like

Add Tintin 3D to the list.
When should I expect the update to be available?


I’ve got a bit going on at the moment, but I’ll get this out for you to test by Monday at the latest.

I’ll then advise you when this is ready.

Thanks for your patience.