3D Frame Packed output

Will the move to 4.9 coincide with the Matrix release (Kodi 19) which I assume is still a long long way off, or do you mean you will update OSMC to 4.9 while still running Kodi 18.x? And does that imply moving to debian buster?

I’m trying to update my osmc to the November build. right now i still have July’s build along with the 9/14 3d beta. when i try to manually update, i’m told there are no updates available. i was planning on updating to the november osmc build and then do the most recent update for 3d. just not sure why there are no updates available from july, 2019.

Thank you for this new 3D test build!

I tried some 3D MKV Movies and everything seems to work as it should. (3D switch on the TV, PGS & SRT Subs, Frame Rate switch).

I have a problem now with 4K UHD Movies and PGS Subtitles: They appear on the left middle of the Picture. SRT Subs work fine. It was the same Problem on the last 3D Test Build, the normal osmc Version works fine.

Log: https://paste.osmc.tv/ugekukuxuv

That was a problem in the previous 3D build as well. From what Sam and Tanio99 are saying, it sounds like we’ll have to wait until after the mainline release moves to the v4.9 kernel before we get a 3D build that addresses that.

If you post a log we can take a look.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

if you require logs (ie this is not behavior for which someone can answer without them), then i guess i’ll have to post logs. however, i was asked to post logs in a previous request for help and have yet to receive any help on that issue (over three months ago, with no hope that it will ever be worked on):

unfortunately to do logs requires time to sterilize them (for example they still include user ids and ip addresses). rather than just receiving a pat answer of “we need logs”, i just want to make sure that this isn’t normal behavior (ie i should be able to receive updates) and that someone here hasn’t seen this issue before and can help.
thank you.

Logs are generally a lot faster and simpler than playing a guessing game about what is going on. If you don’t want to provide them I would suggest looking at your source list (sudo nano /etc/apt/sources.list) and see if you added something to it for test builds or something. You could also manually update from the terminal and look to see what is going on there (sudo apt-get update && sudo apt-get dist-upgrade).

As for you old issue that is a bug that @sam_nazarko is aware of and AFAIK is on the list of things to get fixed.

ok. thank you.

Actually the image shouldn’t necessarily be corrupted but rather overlayed with previous images. Solution is in the works.

thanks for reminding me about how to do this manually. that helped me find the problem and it is now fixed. interesting i had to add the following line to my sources.list:
deb http://apt.osmc.tv stretch-devel main
in the opening post of this thread it indicates to add this in order to do the microcode update, and then to remove this line. Without this line i was not receiving the november update, and with it i did receive the update.
just so you know. thank you.

1 Like

Well could it be that you deleted or replaced the line deb http://apt.osmc.tv stretch main?

i think you’re right! thank you.

Yes, I haven’t had time to look at it, but that issue is still on my todo list :wink:

Thanks for thinking about it. This will make my user experience of the Vero perfect!

Run:

‘sudo apt-get install --reinstall vero3-mediacenter-osmc’

With any luck, a few weeks. I wanted it to be ready for end of next week, but we’re coming up against some tough bugs.

Sam

Oh, cool. :star_struck:

Keep in mind that we want it to be as good as our current kernel is – so this takes time.
We know how fussy you are :wink:

If you need any updates on the timeframe, let me know.

Don’t tempt me. :laughing:

1 Like

Hi there,

I am following the development of the 3D topic since quite a while and was happy to hear that the frame packed output seems to be implemented now.
I followed the explanation to update to the November version.

My current findings are:

  1. When opening a 3D MKV, i have the choice to select hardware acc…
  2. A small info box informed me, that 3D playback is starting, using the hardware

…unfortunately it does not… I am using a SONY VPL 260…

Same files do work properly with a Raspberry Pi and KODI.

After that I tried to follow the next recommendation by adding

deb http://apt.osmc.tv stretch-devel main

and starting the update process. After the update was finished, I did not have the choice of hardware… any more. So I re-installed the previous November version as describe above.

But again no success. Any idea what I could do additionally?

Thanks, Tabaluga73

Please post some debug logs so we can see what’s going on and check if you are on the right version

Sam