3D Frame Packed output

Looking at the log I can confirm that you’re using a version which supports MVC/FP playback. The lines

2020-03-20 14:01:34.417 T:4072218624   ERROR: GetString: error reading /home/osmc/.kodi/userdata/disp_cap_3d
2020-03-20 14:01:34.418 T:4072218624 WARNING: Update3dResolutions: No valid 3D resolutions found.

indicate that your TV did not advertise its 3d resolutions. So 3d playback will not work. Does your TV (which make/model?) support 3d?

Currently I have my Vero 4k connected to my computer monitor which does not support 3D playback.
With what you said this may answer my next question. When I try to play a 3D movie I get a pop-up screen That says:
Select Playback mode
Preferred mode (Same as movie) Cancel
Monoscopic / 2D
Select alternate mode…

I’m not able to remove the pop-up screen and if I select the first option the Vero 4k freezes and I have to remove power to the unit to restart.

I’m just experimenting with the unit trying to learn the in and out of its operating system. This is why I don’t currently have it connected to my 3D TV.

Hm, I’ve never tested that case. I’ll have a look at it. The Vero shouldn’t freeze. Does it work if you select “Monoscopic / 2D”?

I’m not able to select Monoscopic / 2D
The only button on the Vero remote that has any effect is the back button. When you press that button it selects the first option “Preferred mode” then the Vero freezes up and I have to uplug unit to reboot.
This problem only occurs when I try to play back a 3D source (3D.MVC.MKV). I have no problems when I play a 2D source movie.

The up/down buttons do not work?

The Up/Down buttons only give me the option menu for the movie to stop play pause etc.

And they do not work in the “Select Playback mode” menu?

That is correct no effect in the “Select Playback mode” menu.

Only the back button and I can only select the “Preferred mode (Same as movie)” option and then the Vero freezes. Of course I can not get the pop-up menu “Select Playback mode” to clear.

Note I’m using PLEX and until I hit the back button I can still see the movie playing behind the pop-up menu but once I hit the back button the unit freezes up.

Ok, I’ll try to reproduce it here.

You have your “prefered mode” set to ignore. Go to settings>player>video>playback mode of stereoscopic 3d videos> and change it to ask me or monoscopic/2d.

That fixed the problem.
I had it set to “Ask Me”

So what should it be set to automatically select 3D playback once I set this unit up to a 3D monitor?
I set it to monoscopic/2d

I can’t reproduce it here. Maybe it’s a bug in that 3D testbuild? I’m on the current 4.9 build.

Well, that depends on what you want, of course :slight_smile: . If you set it to “ask me” then you get the menu every time you start a MVC movie. If you set it to “preferred mode” then the playback would automatically switch to 3D for MVC movies.

Ok
I did have it set to “Ask Me” and changed it to “monoscopic/2d”
Since I currently have it connected to a 2D monitor this make sense.
I will play around with the different setting and see what happens.

That fixed the problem.
I had it set to “Ask Me”

LOL yep, I mixed up which setting was which in the guisettings.xml. I’m glad that pointed you to something that worked though.

Test builds will now be delivered via the 4.9 testing repository.
Please read the original post again which has been updated as well as the information here: [TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

Cheers

Sam

Thanks Sam
Followed your instructions and installed this new test build.
Tested a lot of my iso 3d, including many with NTSC flag, and all play flawlessly.
Congrats to you and your excellent team.
:smile::smile:

Sounds like it’s all going well 3D wise.

I know the answer is usually ‘when it’s ready’ but do you think the public build will be available within the next 6 months?

There are already public builds and you are welcome to test with 4.9

I think we will be shipping 4.9 as standard within six months.

Sorry Sam, when I said ‘public’ I was meaning a version that everybody has by default. For example when you hit download update and it’s automatically there without special coding or installs. That’s just my bad use of the word public.

Got you. I’d expect that to be available within 6 months, yes.