3D Frame Packed output

Do you still need logs/sample footage from me? Couldn’t tell if gkron92’s issue was the same as mine, or the other 3d issue mentioned a few posts before mine.

No, not at this time. Let me analyse first what the problem with @gkron92’s one is.

1 Like

@tanio99, I’m having trouble reproducing the issue I mentioned with the line down the middle, which I guess is a good thing. If it happens again, I’ll send a log and take photos.

Perfect, thanks!

I agree, those films are particularly bad, but I don’t think that’s the cause for the issue…

Regarding the recent mkv playback issues: it seems MakeMKV has changed the way MVC related private codec data is stored in mkv files. This is the reason for the playback issues. Kodi can’t find that codec data anymore and selects the wrong codec.

Is it fixable?

I think so, yes, we’ll see …

On Previous Beta I had 3D working (installing/activating a beta verion via CLI)
With the current release my Vera 4K+ is not playing 3D frame packed material in 3D? Any idea why this is happening? Should I execute some CLI command to get it working again?


I’ve fixed it (at least I do hope :slight_smile: ). The fix will be part of the next testbuild.


@sam_nazarko Any timeframe for when we might see that next test build?

1 Like

Nice work @tanio99, looking forward to the next build.

1 Like

I don’t have an ETA at this time.
But we keep moving forward with things


Thanks it is working again. Did not realise that 3D was still not in the main image.

I follow all steps to instal 4.9 because i lost 3D, but my Vero 4K+ don´t receive update after reboot. Some solution? I try to install sudo apt-get install --reinstall vero3-mediacenter-osmc=18.6.0-13… but neither works.

Please post logs so we can check if you have set up the repository correctly.

What is the output of this command?

Now works, thanks!

I should be receiving my Vero 4K today and I’m extremely excited!

I’ve ordered it for the MVC 3D support which I know is still a bit unsupported.

Do I need to install v18.6.0-13 using the above command?

Also, I really hope that this feature gets re-implemented back into the main branch for the latest versions!


It will.