3d sbs videos being forced to 2d


I have just had a bit of an adventure but I solved it so I am posting here for future reference for others.

I use vero 4k with a few years old optoma projector that can do 3d.

I had not had problems playing before but with some recent updates, functionality seems to have improved and it caused me some problems - 3d was being forced to 2d for any SBS videos, but playing top/bottom was OK. I tried everything, then eventually looked at the ‘whitelist’ and saw that it was lacking SBS options, only had TAB (over/under) [which worked OK] and FramePacking (which I haven’t used) so following knowledge from

link:Unable to change resolution and 3D reading in Kodi 19.3 ? (solved) - #28 by o.luke

I created ~/.kodi/userdata/disp_cap_3d


720p50hz FramePacking TopBottom SidebySide
720p60hz FramePacking TopBottom SidebySide
1080p24hz FramePacking TopBottom SidebySide
1080p30hz TopBottom SidebySide
1080i50hz TopBottom SidebySide
1080p50hz SidebySide
1080i60hz TopBottom SidebySide
1080p60hz SidebySide

and sure enough it’s all playing right.

The unsolved mystery is why vero is restricting the 3d options to TAB and FP when the projector capability has SBS…

Good luck!


Thanks for sharing your experiences!

The Vero gets the info about supported video modes from the projector which sends EDID info to the Vero where we parse and create the supported modes table out of it. If that mode is not contained in the EDID, then we assume that it’s not supported. In that case it can help to create the file ~/.kodi/userdata/disp_cap_3d as you did. That overrides what was sent in the EDID info.

It might be a bug in our parser or the EDID simply doesn’t contain that mode although the projector seems to support it. In the latter case you’ve already found the solution :slight_smile: .

If you want then just attach logs and we have a look.