Unable to change resolution and 3D reading in Kodi 19.3 ? (solved)

Did you cleaned the HDMI connector?
If cleaning the HDMI port doesn’t fix it post the URL of fw_printenv | paste-log


Yes i clean it and i try to plug it on other cable and TV where other vero4k is working fine…

The URL is :


Many thanks for your support

There is either a cable issue or contact issue with the HDMI connector on your device.

Thanks Sam, i have already change the TV and cable so it schould be the device …

But :

  • I have check it with magnifying glass and everything seem to be ok,
  • i have also vaporize the HDMI connectors with a special contact product (i’m eletronic engineer) …
    and it’s the same… Only two resolution is proposed…

How can i go further now ?

Did you try the cable on the working Vero?

Yes i don’t work. I try to plug the one witch don’t work instead of the working one (with a good cable and tv). It don’t wokr, i have the same result.

What can i do ?

Hello, what can i do know to know the problem and to fix it ?

Try putting this:


In this file:

1 Like


There is no file you have mentionned in this repertory :

osmc@osmc:~/.kodi/userdata$ ls
Database       RssFeeds.xml  Thumbnails  favourites.xml  guisettings.xml           keymaps  mediasources.xml  peripheral_data  profiles      sources.xml     wakeonlan.xml
PartyMode.xsp  Savestates    addon_data  fstab           guisettings.xml.restored  library  passwords.xml     playlists        profiles.xml  upnpserver.xml

The cap_disp is exist …

Any idea ?

You have to create the file:

nano ~/.kodi/userdata/disp_cap

Note it’s disp_cap, not cap_dist

1 Like

It’s work !!! many thanks : i can change the resolution now !!! Much thanks !!!

But 3D isn’t working … And i don’t know why: On a other vero4K i have exactly the same parameters for 3D and screen (1920x1080P (2D), 3D reading is based on based on hardware) and with the same blueray 3D file it’s work…

Is written on tv (instead of witching in 3D) :
“Mode 3D stereoscopic . monoscopic / 2D”

I don’t know why, any idea ?

OK, we need to be a bit more sophisticated. Please plug your ‘good’ Vero into the TV you want to use with the ‘bad’ Vero and post logs:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks Grahamh but i’m not sure to understand the value added of this. I wouldn’t break the good one wich is in the main lounge… :wink:

The ‘bad’ one was working well in kodi 19.1 with this cable and TV (untill i try to plug a HDMI to VGA with PC monitor. Now i put back the right cable and TV…).
After that the ‘bad’ one was blocked to low resolution.

Now the resolution is great with your good advice and JohanBakker one. But the 3D Blueray isn’t working. For information, few days ago, the “good” one update to 19.3 Kodi version (19.1 before) and the Blueray 3D had the same issues (not switching TV in 3D, written “Mode 3D stereo-monospcopic 2D”)… I try some random manipulation (x*y resolution in 2D, 3d, …) and it come to work. I don’t really know how.
Note the “bad” one is also now in kodi 19.3.

I try to backup the good to the bad without sucess.

I have read some post :
Playing 3D Blu-ray in 2D - Help and Support - OSMC Forums

That is was a bug to read 3D blueray. But it is working on the good one (1920*1080p 2D 59.94 hz).

Sorry for this long post.

Do you think the log of the good one with Cable and TV of the bad one still help ?

Otherwise what could i do ?


The 3D resolution modes are listed separately from the 2D modes. If your device is not getting the EDID from its display we need to specify the 3D modes in a file called disp_cap_3d. But we don’t know what modes your TV supports unless you can connect a good vero to it and get the logs.

If you are sure this problem started only when you upgraded to 19.3, you could reinstall 19.1 from the August 2021 release.

Ok thanks for explanation. The ‘bad’ one is in a children bedroom, so i’ll will post it tomorow.

I would prefere to stay in 19.3 but if we don’t fine solution i will try to downgrade to 19.1…

Many thanks for support,

Downgrading is certainly not ideal, but if it cures the problem, we might, with logs, get an insight into why the latest release is not working.

Keen to see the logs.



The ‘good’ vero log (on the bedroom cable and TV) is
The 3D blueray is perfectly working, koidi is in 19.3, resolution is 1920x1080P (2D)

The “bad” vero log is :
The 3D blueray ARE NOT working (i have “Mode 3D stereoscopic . monoscopic / 2D” message on screen), kodi is in 19.3, resolution is 1920x1080P (2D)

I hope it will help to investigate.

Many thanks to tell me what to do.

Instead of what @JohanBakker suggested, your disp_cap file on the ‘bad’ vero should look like this:


and you need to make a new file ~/.kodi/usersettings/disp_cap_3d with these lines:

720p50hz FramePacking TopBottom SidebySide
720p60hz FramePacking TopBottom SidebySide
1080p24hz FramePacking TopBottom SidebySide
1080p30hz TopBottom SidebySide
1080i50hz TopBottom SidebySide
1080p50hz SidebySide
1080i60hz TopBottom SidebySide
1080p60hz SidebySide

That should give you the 3D modes you need. Let us know how it goes.

It’s perfectly work !! Yes !!

Many many thanks Grahamh and all of you for your support !!!

And happy new years !!