Unable to change resolution and 3D reading in Kodi 19.3 ? (solved)

I have Two Vero 4K+ with kodi 19.3 :

  • On the first one my resolution is 1920*1080P(2D) and i have many choice in the resolution combo list
  • on the second one i have only two options: (720480P (2D) and 1280720p (2D) . 1280*-720 can’t play 3D Blueray …

Do you know wy i haven’t the complete list of resolution in the combo ??

(I tried back first vero to second without sucess… This append since i tryed a other TV on the second one. I put back the previous TV (3D one) but no change : my resolution have only to basic choice…


Many thanks and merry christmas

Upload logs via MyOSMC - Log Uploader and share the URL.

Also have you checked the HDMI cables and tried to connect the Vero to the other display?

My log are here :

Note : I have the same TV screen and the same cable as before (when i had hightest resolutions, and 3D working…)

You clearly have a broken EDID reported. Suggest to check the cable and possible clean the contacts.
Or as mentioned maybe try the Vero on your other TV to see how it react there.

====================== Display Cap CTA =================== g0gjk991

---------------------- Display Cap CTA END --------------- g0gjk991

====================== EDID =================== wE0go885
Rx Manufacturer Name: 
Rx Product Code: 0000
Rx Serial Number: 00000000
Rx Product Name: 
Manufacture Week: 0
Manufacture Year: 1990
Physical size(cm): 0 x 0
EDID Version: 0.0
EDID block number: 0x0
blk0 chksum: 0x00
Source Physical Address[a.b.c.d]:
YCC support 0x00, VIC (native 3):
ColorDeepSupport 0x00 10/12/16/Y444 0/0/0/0
3 4 16 
Audio {format, channel, freq, cce}
{1, 1, 0x07, 0x01}
Speaker Allocation: 0x00
Vendor: 0x000c03 (HDMI device)
MaxTMDSClock1 75 MHz
vLatency:  Invalid/Unknown
aLatency:  Invalid/Unknown
i_vLatency:  Invalid/Unknown
i_aLatency:  Invalid/Unknown
RR_Cap: 0
LTE_340M_Scramble: 0

checkvalue: 0x00000000

---------------------- EDID END --------------- wE0go885

Ok many thanks, i’ll try tomorow and i’ll tell you: try on other TV first and clean the cable in second.
Just to know is there a way to setup the list or it’s a hardware checking without any software intervention ?

Hello, i have tried on the other TV with super HDMI cable and it’s the same ; i only have two choice 480p60hz and 720p60hz. How can i fix it ??

Hi Fzinken, any advice ? i tryed on other TV with other cable (where the first Vero is worked) and i have the same issue .

Many thanks

Did you cleaned the HDMI connector?
If cleaning the HDMI port doesn’t fix it post the URL of fw_printenv | paste-log


Yes i clean it and i try to plug it on other cable and TV where other vero4k is working fine…

The URL is :


Many thanks for your support

There is either a cable issue or contact issue with the HDMI connector on your device.

Thanks Sam, i have already change the TV and cable so it schould be the device …

But :

  • I have check it with magnifying glass and everything seem to be ok,
  • i have also vaporize the HDMI connectors with a special contact product (i’m eletronic engineer) …
    and it’s the same… Only two resolution is proposed…

How can i go further now ?

Did you try the cable on the working Vero?

Yes i don’t work. I try to plug the one witch don’t work instead of the working one (with a good cable and tv). It don’t wokr, i have the same result.

What can i do ?

Hello, what can i do know to know the problem and to fix it ?

Try putting this:


In this file:

1 Like


There is no file you have mentionned in this repertory :

osmc@osmc:~/.kodi/userdata$ ls
Database       RssFeeds.xml  Thumbnails  favourites.xml  guisettings.xml           keymaps  mediasources.xml  peripheral_data  profiles      sources.xml     wakeonlan.xml
PartyMode.xsp  Savestates    addon_data  fstab           guisettings.xml.restored  library  passwords.xml     playlists        profiles.xml  upnpserver.xml

The cap_disp is exist …

Any idea ?

You have to create the file:

nano ~/.kodi/userdata/disp_cap

Note it’s disp_cap, not cap_dist

1 Like

It’s work !!! many thanks : i can change the resolution now !!! Much thanks !!!

But 3D isn’t working … And i don’t know why: On a other vero4K i have exactly the same parameters for 3D and screen (1920x1080P (2D), 3D reading is based on based on hardware) and with the same blueray 3D file it’s work…

Is written on tv (instead of witching in 3D) :
“Mode 3D stereoscopic . monoscopic / 2D”

I don’t know why, any idea ?

OK, we need to be a bit more sophisticated. Please plug your ‘good’ Vero into the TV you want to use with the ‘bad’ Vero and post logs:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks Grahamh but i’m not sure to understand the value added of this. I wouldn’t break the good one wich is in the main lounge… :wink:

The ‘bad’ one was working well in kodi 19.1 with this cable and TV (untill i try to plug a HDMI to VGA with PC monitor. Now i put back the right cable and TV…).
After that the ‘bad’ one was blocked to low resolution.

Now the resolution is great with your good advice and JohanBakker one. But the 3D Blueray isn’t working. For information, few days ago, the “good” one update to 19.3 Kodi version (19.1 before) and the Blueray 3D had the same issues (not switching TV in 3D, written “Mode 3D stereo-monospcopic 2D”)… I try some random manipulation (x*y resolution in 2D, 3d, …) and it come to work. I don’t really know how.
Note the “bad” one is also now in kodi 19.3.

I try to backup the good to the bad without sucess.

I have read some post :
Playing 3D Blu-ray in 2D - Help and Support - OSMC Forums

That is was a bug to read 3D blueray. But it is working on the good one (1920*1080p 2D 59.94 hz).

Sorry for this long post.

Do you think the log of the good one with Cable and TV of the bad one still help ?

Otherwise what could i do ?