4k+ CEC EARC issue

Hello,
I have Vero 4K+ connected to Samsung MS650 soundbar, which connects to LG OLED55B7V E-ARC. It had been working fine for over 2 years. Recently though turning the TV on failed to turn on the soundbar, worse even if I manually turned on the soundbar I would get no sounds from the terrestrial tuner.
If I power down everything (that connects to TV/soundbar) then it works again for one, sometimes two sessions. I put it down to either faulty TV or soundbar. But I saw another post here where Sam said power down everything to clear the CEC bus.
I’ve updated the Vero as each update came out, and I would guess I’ve had this issue for around 3 months. I now suspect it was a Vero update that caused the issue.

This morning I switched on TV test #1 (OK, all working), after each test I switched TV off. Test #2 (OK). #3,4,5 (Not ok). #6 Removed power from Vero, and turn on TV (OK). #7 (OK). #8 Reconnect Vero (Not ok), Enabled debugging in Kodi. #9 (Not ok).
Test #9 TV switch on can be found http://paste.osmc.tv/yoxayesivu

Thanks in advance, hope it makes sense.

I am running into a similer problem. Vero 4K+ and Sony TV connected to a Yamaha receiver. I turn on the TV and the receiver turns on. Been working fine for years. Since the last Vero update I have the same problem. Turn on the TV and receiver does not turn on. Power cycle everything and it works for a few cycles but then stops. Unplug the Vero and all is fine. Plug the Vero back in and works for a few cycles then quits working.

Have you tried powering down everything at the mains for a few minutes?

Sam

Hi Sam,
Looks like Joe and myself have the same issue. It works for a few cycles when everything initially powered on. Powering everything off or rebooting Vero fixes it.

I can confirm I have the exact same problem since the latest update.
Phillips TV. JBL 5.1 set. The Vero4k+ hooked up to that JBL set. Turn on TV, JBL doesn’t come on anymore. If I unplug the Vero and retry than it works.
How can we fill a proper bug report?

We’ll get this solved – don’t worry.

Can you try some logs on initial boot when it works and some logs when it doesn’t work?

Please see first post for logs when broken.
I’ve just switched TV on (all working), rebooted Vero. Started logging. Switched TV off (5:06)/on (5:07) all still working. https://paste.osmc.tv/apugerudof
Thanks.

Same here. On the latest release and still having issues with CEC. LG TV with LG soundbar, with the VERO 4K+ connected the soundbar does not want to go in ARC mode. When I reboot the VERO 4K+ it activates ARC without an issue. (LG manages this trough their implementation of ARC).

I’ve already disconnected everything from the mains for a few hours.

PS: the issue only happens when everything is off (stand by) for a few hours… When I turn off & on TV/Soundbar/Vero within a shorted time it keeps working…

To follow. My setup is new and cannot tell from where the issue is really coming but I see two problems that are in the topic’s area

My setup: Vero4K+ > soundbar > TV
(CEC-eARC)
Vero fresh install with last image and updated

1/ Put the TV in standby and start it up makes the source change to Vero every time. I played with CEC adapter in the parameters, no luck so far

2/ After a couple of days (more than 1 at least) I’ve already experimented the soundbar switching fast between sources (TV/Vero) ending by a disconnection of the eARC. The display on the soundbar was showing the fast witching and the sound source is ending by only TV speaker (no bar). The first time I put all OFF and start things again, the second I disconnected the power of the Vero and it was enough. It happens more than once but for the sake of clarity…
Between issues, no problem at all

EDIT: well it last less than 24h to get it again. Power on the tv (soundbar follow) and the sound switches from tv speaker to soundbar multiple times. Going to CEC adapter option and disable/enable it makes it handshake again (brief black screen attests it) and the problem was instantly gone. Not other hdmi device connected, nothing done on the tv or soundbar for the sake of test.

We’ll get this solved – don’t worry.

Can you try some logs on initial boot when it works and some logs when it doesn’t work?

Hello Sam. I provided working/non-working logs. I think we are all saying is “initial boot” works for all of us. Its just a few TV on/off’s later if stops working. Happy to provide whatever you need, but please be explicit what you need. Thx :slight_smile:

My HDMI chain is Vero 4K+ --HDMI–> Prism+ Q65-QE TV <–HDMI-- Panasonic soundbar, i.e both devices connected to the TV through HDMI ports 1&2, and I have the similar problem above.

CEC issues only crop up when the TV is on standby for a long while (18-24 hours). If the TV is turned back on in shorter periods (3-4 hours) it never crops up.

In all cases, power down at the wall plug and powering all back up again fixes it.

Have been noticing this behaviour since Sept/Oct updates, but not before that.

Hope this helps add some light into it.

Just wanted to +1 to this issue.

On my setup - which has worked perfectly for years with CEC - I find that CEC works initially, but upon an extended period (>12h), CEC works perfectly with Vero 4k [1] (ie, my TV / AVR turns on / off) but no other devices work. The current ‘fix’ is to reboot Vero 4k & replug the HDMI cable. Once I do that, everything is fixed (…until later that day when it breaks again after being in standby).

[1] (Sony X900E > Denon AVR 2700H > Apple TV 4k (2021) & Vero 4k)

This sounds very like the problems in this thread HDMI-CEC seems to stop working after a couple of hours - #148 by sam_nazarko that I and a load of others were having after updating to the September update. I can see a few other HDMI or CEC-related threads recently too from users on the latest update.

In my case it certainly looked like it was CEC-focussed at first and a few attempts were made to fix, but it looks like from reading this (and those few other recent other threads) that even now that the CEC changes were reverted to the same behaviour as in 2022-03 there is still some weirdness here.

I personally reverted completely to 2022-03 and it’s been rock solid for me and I can’t/won’t update again until this is ironed out as the behaviour for me was completely hijacking the whole chain causing not only the Vero but other devices to play up and not only unable to be controllable via CEC but also sometimes to not even output audio via the AVR after an unspecified period of time etc.

@sam_nazarko - in this post: HDMI-CEC seems to stop working after a couple of hours - #106 by sam_nazarko you said there had been some changes to the HDMI TX PHY drivers made by AmLogic which you had included which could have been the cause - did you investigate this further?

I removed Vero 4k from my setup yesterday. Turned on Apple TV this morning and, as expected, TV & AVR power on. Removing Vero 4k is the only fix so far. Please do your magic @sam_nazarko and team :slight_smile:

I switched back to 2022-3 release this morning. It drove me crazy yesterday when it kept happening it and even ended up with the TV and the sound bar both playing the audio at the same time. Downgraded and now all works fine again. I’ll wait for the next update with a fix :blush:

After reading these posts about CEC, is it JUST the vero that stops working with CEC/HDMI (no effect to other devices, such as AVR or anything else)? or can it actually be causing issues with other devices on the CEC/HDMI chain (such as the AVR being unable to negotiate an HDMI sync)?

I’ve recently suddenly started having some HDMI issues with one of my TV setups (vero4k → Sony AVR → Samsung TV), which initially also had a Roku Ultra attached to the Sony AVR, and it started acting up (hdcp complaints from the roku all the sudden, and HDMI handshake issues). And after sitting off overnight, the TV would say it gets no signal from the AVR. I at first blamed the cables, swapped them out a bunch, and ended up buying a whole new set of 8K certified cables from monoprice, which I assumed was overkill. Problem did not go away, I then blamed the Roku, and ripped it out (the TV is a smart TV so I plugged in the ethernet cable and set up the apps so my wife can use those on the TV instead of the roku). TV still gets “no signal” problems from the AVR after sitting in standby overnight, which is a real pain, because it uses the Arc to the AVR for audio. Unplugging everything from the wall and plugging back in always fixes it (for a while). I’ve disabled CEC on the Vero (the universal remote I have has a lot more buttons than the TV’s remote anyway), but still the AVR and TV end up with handshake issues.

Up until now, I was concluding that the HDMI ports on the TV must all be going bad (have rotated through all kinds of connection options, different ports on TV, connecting devices directly to TV instead of through AVR, etc) and have been contemplating whether we need to replace the 3 year old TV already. I have not tried removing the Vero from the chain, because that is what my wife uses the most (the PVR with tvheadend on the backend)

So, could these CEC issues actually be causing the kinds of problems I’ve been seeing (which appear to involve other devices on the chain, not just the Vero)? or is the Vero unlikely be involved in the HDMI handshake problems involving other devices?

Like others when the issue ocures I reload the Vero. I use Android Yatse app to do it. After reload, the soundbar comes on and TV switches to eARC. Good for another day or so.

No. Vero’s CEC connection works just fine! It’s just every other fucking device that breaks until Vero is removed from the CEC chain.

For me the Vero is fine, other devices suffer (eARC between soundbar and TV). I disabled CEC on the Vero too, but experience problem again, as you it seems. I know disabling CEC inside Kodi does not guarantee no CEC “traffic”, I made post in this forum some years ago about a different setup but still. At this time adding a specific device to my TV (HDMI) broke the CEC connection between my TV and OSMC after some hours. The device was CEC hardware capable but the software was not, with no drivers loaded. It ends with an Amazon adapter for the HDMI cable with CEC not connected. It still work today.

But yeah maybe a different story here :).