4k+ CEC EARC issue

Have you tried one device at a time?

We did have some issues around September and we resolved them. The forums are quiet again.

You didn’t provide any logs so I don’t even know what version of OSMC you are on.

Not sure what you mean by one device at a time? I just need to remove V4k from my setup and CEC springs into life with other devices.

If I unplug hdmi from V4K and reboot, it’ll be good for another 12-18 hours, then it’s buggered again. I’ve removed V4K from my setup as I can’t deal with this anymore. Everything CEC wise has been perfect since then.

What logs do you need?

Just pinged you a DM with two logs.

I’ve noticed that Vero4k will not go into Standby mode when the TV is turned off (it previously would do). If I check ‘send inactive source command on shutdown’ the V4K refuses to enter Standby mode. CEC is just broken somehow in the latest release.

Don’t think they were resolved. I moved back to 2022-03 and gave up.
I know you out the old cec code back, but it didn’t fix it - there must be something else going on.

I’m having similar problems. Took me a while to figure out what caused it. I even reset my AVR and TV to factory settings. My setup has been working flawlessly for a long time. I’m not using my Vero 4K+ regularly at the moment, so I had been on 2022.03 until a bit over a week ago when I updated to the latest version. This post from the other thread quite accurately describes the problems I have had too: HDMI-CEC seems to stop working after a couple of hours - #18 by rodhull.

My Vero 4K+ is connected to a Marantz NR1711AVR (along with some other HDMI devices), and the AVR connected to a Sony X85J TV. I have enabled debug logging, let’s see if I can provide anything that helps.

Update: just a small test done this morning, nothing new but if it rings a bell

Setup: Vero>soundbar>TV, CEC adapter disabled in Kodi. However…
As usual each xx hours I see eARC issue (topic related) between my soundbar and TV, TV switches to TV speakers only when resuming from standby. This is only the case when eARC/CEC issue happens, the rest of time all works w/o problem.

With the TV ON:

  • Waiting 10min, no change. The soundbar is not available with eARC
  • put the soundbar in standby, resume. No change
  • Remove the Vero4k+ HDMI cable (not power), put the soundbar in standby and resume >> success. I’m able to select again soundbar eARC on my TV.

Same here for me Vero 4k+ & Sonos Arc interference - #2 by shamael

Can get you logs if needed.

I reverted the CEC driver to the state it was in prior to the OSMC September update with updated video stack for Vero 4K / 4K +

Unfortunately logs since then have been sparse and any attempts now are stabs in the dark…

I will see if I can reproduce CEC issues. We get it solved, but I need more information.


Soundbar eARC again in trouble but able to access SSH at this time.

  • Kodi CEC is enabled
  • Vero was behaving right then eARC between soundbar and TV brokes again
  • no reboot or HDMI removed (from OK to NOK so)


I have similar issues like mentioned before. My setup is as follows: Vero 4K+ and CXUHD connected to NAD T778 AVR. T778 connected to LG OLED65C9PLA TV for video and eARC. Was fully working as expected: I could control the Vero and CXUHD with the TV magic remote and listen to (lossless) audio coming from the TV.

Issues include:

  • Loss of volume control from the TV remote of the AVR
  • eARC output loss
  • Can’t control Vero or Bluray with tv remote.

Not all of them occur all at once. After switching off the CEC functionality of the Vero it all works as expected. After reenabling the CEC it work for minutes to weeks. Last evening it stopped working again. I enabled libCEC logging after the last fault, so hopefully this logs can help identifying the issue:


I also have similar issues although my TV and soundbar are older so they don’t support earc just arc.

I have two lg oled b7 models, one is connected a a Samsung ms750 soundbar and another connected to a Cambridge audio soundbar.

Both have issues with arc now, has been this way since at least October. Has taken me some time to realise that it’s the Vero after disconnected the Vero and seeing if we keep losing arc.

Have been using the Vero since 2018 not had this issue before.

Update from my side: yesterday my LG OLED tv lost HDMI ARC audio again while the CEC was disabled on the Vero (!). Rebooting the Vero solved the ARC issue between TV and AVR. So maybe that gives some direction on where to look for in solving this bug. New log attached: https://paste.osmc.tv/hazekigaci


As stated earlier in this thread (or related CEC) my TV powered ON by itself. As I’m not always in the room I cannot tell how many times it happens, TV self-shutdown after 4 hours as default settings.
It happened in the last 20 min, here are the log if relevant https://paste.osmc.tv/qetehecivo

Thanks for the logs.

I was using my Google-Fu skills to try and find out what each of the CEC menu options do and I found this on an old post regarding LibreCEC. It might be useful and then again might not be.

My thought process and it seems to be common amongst other having the issue is that the CEC bus is seeing the Soundbar/Amplifier and not the devices (mainly the Vero) connected to the Soundbar/Amps. For example my Soundbar is connected to HDMI 3 on my LG OLED via CEC and then my Vero 4K+ is connected via HDMI2 on my Soundbar. Perhaps this is what is causing the issue? Others is this post have seen the same behaviour.

I’m not switched on in these things, but tried setting the Physical Address to 1000 and didn’t receive positive results. Perhaps I need to change the physical address number to reflect?

Hoping others can chime in?


This issue is about 8 years old – so I’m not sure this would be the issue. Furthermore, that issue seems to suggest the problem only occurs after the device enters standby mode.

I am looking in to it – but I’m not expecting an overnight fix, to be completely honest. But we will get it solved.

Thanks for your patience



1 Like

For me personally and as other have said it occurs after a period of standby. I know how hard you work to resolve issues, just thought I’d chip in with some alternatives.

Have a great festive period.

And you



I can confirm that I also had the same issue described in this thread. Fix for me was to roll back from 2022.10 to 2022.03. All works fine now again.

My setup: SONY KD-65XG9505 + Denon X3500h. Vero4k+ together with xbox and TV set-top box.

If there will be fix at some point, then can test again and upgrade. If no fix, then I’ll need to stick to 2022.03 :slight_smile: Good luck with the fix.

I’m in the same boat as you - I went back to 2022.03 to enjoy a fully stable/working system after the last changes did not seem to fix things fully relating to HDMI switching/ARC - this and a few other threads I’ve seen pop up recently sound similar to the things I was experiencing so I suspect things are still not right in the latest version. I too have a Sony TV and a Denon AVR with a few other HDMI devices connected and the Vero from the September update onwards would randomly “hijack” the TV/AVR and its inputs, either stopping CEC from working as expected, or at worst stopping the routing of audio from the Vero (or even other devices connected to the AVR) via the AVR speakers and forcing the TV speakers to be used - no matter what I did on the TV to try to force the AVR to be used, it would always complain about connectivity issues to the AVR and nothing would work until the Vero was rebooted upon which everything started working perfectly again (with no other changes or reboots necessary on other devices), all until it would randomly begin again after a time - could be a few hours or days but it would always happen eventually and it was 100% the Vero causing it since a reboot of the Vero would cure it every single time. Only going back to 2022.03 has ultimately fixed it for me and I’ll have to stay here for a stable system unfortunately.

@sam_nazarko - in the main larger thread when discussing these problems seemingly introduced following the September update you had previously mentioned “There’s a big bump from SoC provider in the September update and a lot of changes to the HDMI TX PHY drivers. My suspicion is that the problem is there and there may not necessarily be any CEC issues.”

Did you ever manage to do any digging to confirm this? Now there are a few other threads (including this one and some more updates from other users to the original large thread) now reporting HDMI/CEC/eARC issues such as:

Might it not seem sensible to assume they could all be connected to the original issues that were never fully fixed?

1 Like