Another Vero 4k+ CEC issue

I’ve been running osmc since launch on raspberry but now finally upgraded TV and bought me my first Vero 4k+.

I have tried looking through for similar issues here on the forums but can’t find a post that describes the issues I’m seeing.

I have a QN85A samsung TV that plugged by HDMI to my AVR (Onkyo TX-NR535).
Xbox S X plugged directly to TV (for 4k 120Hz) and from TV to AVR for CEC and ARC
Vero 4k plugged via provided HDMI to AVR.

  • volume control on AVR works with both TV and OSMC remote
  • everything works as expected with TV remote when I run Kodi on Xbox, I can control AVR volume and navigate the menus.
  • I can navigate Vero/kodi with AVR remote

I have two CEC related issues since I plugged Vero in the enviroment;

  1. In the middle of the night, approx at 2.30am the TV and AVR are beeing turned on

  2. Can’t navigate Vero/kodi with TVs remote

After yesterdays October update my Vero is beeing recognized as “Recorder” by the AVR where it previously was recognized as “Kodi”

Hope someone can help me resolve these issues, thanks

have a look at 4k+ CEC EARC issue

If you could post some logs this would be quite helpful.

Particularly with this…

Let’s pause this thread for a bit since I switched over Vero to be connected directly to my TV instead (realized my AVR wasn’t capable of HDR)

I got CEC working after some fiddling and resetting settings, however, the source icon is missing and it’s still discovered as a recorder, but that’s no biggie as long as it works :grin:

I’ll try and post logs next time the device turns on in the middle of the night. Can I now turn on specific debugging and leave it on to try and catch this event, or will the logs get too flooded?

The TV is right behind my working desk, I get the same thing with CEC disabled inside Kodi, a ‘live event’ when I was present. As even with the CEC disabled I get the eARC issue I re-enabled it and it didn’t happened so far. If so I’ll provide logs