4k doesn't work in the Youtube Addon

I’ve recently tried to setup the official Youtube addon for 4k on my Vero4k+ and got it to kind-of work. I get sound as expected but the picture is not working. If I select 1080p or 2160p resolution in the plugin, the following happens to the picture, but as mentioned sound plays perfectly fine and 720p or lower works fine with the plugin, but can’t get 1080 or higher to work.

Linux osmc-01 3.14.29-160-osmc #1 SMP Sun Sep 13 13:55:21 UTC 2020 aarch64 GNU/Linux

Anyone got any ideas, some setting I missed while setting the addon up for 4k?

Same here… VP9 seems to be the culprit…

cheers
Anthrax

It’s hard to speculate without logs.
It would also be good if others could verify if this is an issue on the new 4.9 stack.

Hi @sam_nazarko , I can grab logs from my end on this tonight when I have a chance to test some more.

I just played a 4k VP9 file on my Vero (with Kernel 4.9) and didn’t had a problem.
I played the file from a file. I can try later via Youtube

I’ve never had an issue with local files, it seems to only affect videos streamed via the Youtube addon with VP9.

Ok also tried via Youtube Addon. Working here. But that is with Kernel 4.9.

Also no issue with 4K on YouTube with 4.9 kernel. (Other than the longstanding known issue that it doesn’t trigger HDR correctly).

@sam_nazarko

I’ve uploaded logs with the built in tool.

You have to post the link that you get

I sent it in private to sam :slight_smile:

Hi @sam_nazarko have you had any chance to look into this? I sent the log id to you in a private message.

Do you have the new kernel installed?

Hi @n4orcer – I get about 150 messages a day.

Is it possible for you to post the logs publicly?

Sam

Stupid question - but are you also running Hyperion on the Vero4K+?

If you are, and you stop the service, and then try the video again - does it play ok?

@GoldenEyes I am actually. I tested with stopping the Hyperion service, and then it played normally and as expected.

So I guess it’s something with when Hyperion is enabled with it’s frame grabber?

@sam_nazarko The logs are here, but since it works when Hyperion is disabled, I guess this is an issue on Hyperion side perhaps?

I had the exact same issue with my setup - never worked out what the issue was. May be worth posting in OSMC and Hyperion to see if anyone can help (now there’s at least two of us!)

(original of me posting about issue here OSMC and Hyperion)

I’d suggest raising this in the Hyperion thread and checking if it’s an issue under the upcoming 4.9 kernel

Sam

Hey everybody,

might this issue be connected to the hyperion 4K workaround that ist automatically used by @hissingshark’s installer/hyperion service:

see: /usr/share/hyperion/bin/drmctl.sh

 #!/bin/sh

if [ -d /sys/module/amvdec_h265 ] && [ -d /sys/module/amvdec_vp9 ];then
    case "$1" in
    "start")
    sudo chmod 0666 /sys/module/amvdec_h265/parameters/double_write_mode
    sudo chmod 0666 /sys/module/amvdec_vp9/parameters/double_write_mode
        echo 3 > /sys/module/amvdec_h265/parameters/double_write_mode
        echo 3 > /sys/module/amvdec_vp9/parameters/double_write_mode
    ;;
    "stop")
    sudo chmod 0666 /sys/module/amvdec_h265/parameters/double_write_mode
    sudo chmod 0666 /sys/module/amvdec_vp9/parameters/double_write_mode
        echo 0 > /sys/module/amvdec_h265/parameters/double_write_mode
        echo 0 > /sys/module/amvdec_vp9/parameters/double_write_mode
    ;;
    esac
fi

# contributed by Lancelot on the OSMC forum
# fixes glitches when using Hyperion with 4K content

I’m moving to 4.9 again for testing now. Will report back.

2 Likes