4k file won't play, but used to

I have a 4k file that previously played without issue (TV - Panasonic 50DX750) but now when I try to play it, I get nothing.

With this TV whenever I play a file, screen goes black and adjusts settings then file plays. Settings are displayed on screen (resolution, refresh rate). But with this 4k file I literally get nothing now. No resolution or refresh rate, just a black screen. After a bit I press stop on the remote and it goes back to the menu screen.

Attached two debug logs - first one with the component logging enabled, second one without it enabled. not sure which you’d want.

File is being played from network storage, and there’s been no changes to my network since the file was last successfully played.

https://paste.ubuntu.com/26312364/ - with component logging

https://paste.ubuntu.com/26312375/ - without component logging

That file won’t play: Rogue One: A Star Wars Story 4K VISIONPLUSHDR-1000 Chroma Subsampling 4:2:2 Edition

A user had the same problem with this file the other day: Buffering issue even from a usb?.

Not sure if it’s exactly the same, as my file is something like 6.5GB in size whereas that one on the linked thread is 45GB?

And it used to play fine for me a month or two ago, but doesn’t play now.

And unfortunately at this time that’s my only 4k file.

Can you let me know which version of OSMC it used to play on? Can you try downgrading to that version?


I’m currently on osmc running Kodi 17.5 compiled Oct 29 2017. Osmc 2017.10-1. kernel Linux 3.14.29-42-osmc

No idea what version I was on when it did work. What version was out about two months ago? Or most likely the version prior to the one I’m on now?

I’m not really sure why the file would have stopped playing. If you can tell me specifically which one it did work under, I can investigate this further. I am pretty sure that the issue is with this file however.

Unfortunately unless there’s a history log for versions that were previously running, I have no idea what version I was on. If there’s a way to easily roll back to the previous release, I can try that to see if it works again. Then try each previous increment for the last several months to see if any work.

It may well be the file, but as it has played fine previously, it at one point was compatible enough!

Well grab-logs -a will provide the apt log which should show when which version was installed.


That’s the grabs-logs -a output file.

There’s lots of dates in there, with the most recent being 30 Oct. Unfortunately I can’t remember when it was that I played the file when it worked. I think it was mid Nov, but it could have been earlier. I just know with 100% certainty that I have previously played this 4k version of Rogue One.

I’ve now acquired another 4k file, which plays fine on my pc, but again won’t play on my Vero 4k.

Log here: http://ix.io/XBh

Same thing happens. TV goes to black screen, but nothing updates. No resolution change, frequency change.

I tried it before and after the latest update and same both times.

Are there settings i need to change to play 4k files?

It would useful to see the mediainfo on files that are problematic. Info on obtaining that info is here

No problem, will get on that tomorrow as it is late now!

The file also plays fine when playing through my TV’s built in media player from my media server.

This should be the media info for the file.


I’ve now tried playing the file from a usb3 stick plugged directly into the Vero unit, and it didn’t work.

So only way it currently plays in my TV is through the TV’s really crappy media player interface.

Any help on how to get osmc to play it would be appreciated!

Please try updating and try again. It could take an hour for this update to reach your mirror.

As a side note, the Bananna Pi you seem to be using for SMB has some issues with reading files; so changing SMB version may help things.

Failing that, we’d need a small sample to reproduce the problem to see what’s going on.


I’ve updated again, but still the same. To give more reference points I’ve also downloaded several 4K samples to see if they played through OSMC, and absolutely none of them did. All did the same as before, after clicking to play, screen goes black and… nothing. No notification on the TV of change of resolution or frequency. Nothing.

The samples I’ve downloaded are from the kodi samples page here: https://kodi.wiki/view/Samples
I’ve tried from the 4k section, numbers 8, 9, 18 and 20.
From 4ksamples.com I downloaded the Elysium sample.
from x265.com I’ve downloaded the short Big Buck bunny clip h264 version.
And I’ve cut a 1 min sample from the Last Jedi.
None played through OSMC, but every single one of them played when using my TV’s media player interface (although the audio was not supported on the Elysium sample).

I did have buffering issues playing using my TVs media player with all but the Last Jedi sample and Big buck Bunny when playing over my network from my media server, but when on a USB stick plugged in to the TV they all played fine.

On the same USB stick, none played from there on OSMC when plugged directly into the Vero.

I don’t have a clue how to change SMB version with the BananaPi. I haven’t touched it for years since I set it up. I can try to update it if necessary, but as I am not 100% sure what settings I’ve set up on it, I’m hesitant to do anything with it in case I don’t get it set up again right. I’ve not noticed any issues with it when playing anything so far…

I can upload the sample Last Jedi clip somewhere if needed, but given that I can’t get a single 4k file to play, that suggests it is more than just that one file.

Are there settings in OSMC somewhere that I should have changed to enable 4k playback? Hopefully it is as simple as that!

If there is a 4k sample somewhere that you know with 100% certainty should work fine through the Vero, then I’ll download that and give it a try too.

Please try updating your device, and then trying:


It’s a CBR of 120Mbps, so you’ll need to play it over WiFi (a good WiFi connection) or local storage to avoid stuttering. This is a 10-bit 4K HEVC file; which is the most typical format you’ll find 4K material in.


Updated my osmc, downloaded the jelly fish file, but still doesn’t play. Still get black screen of nothing happening.

Log file: http://ix.io/Ywf

File plays fine on my TV’s media player.

The logging into overlay that appears when logging is enabled, does not show when I have the black screen of nothing.

Please upload full debug logs via My OSMC. Your log doesn’t show any attempt to play any files.

Did you restore Kodi settings from another device? Sometimes, if you restore guisettings, you also restore the external player options, which will cause problems when moving to another device.

Moving your ~/.kodi directory should solve any playback issues you have completely, otherwise something else is not right with your setup.


Sorry. Hadn’t realised there was a log uploader in the my osmc. I’ve been using a different log uploader plugin.

Anyway, hopefully that’ll have all the required info.
What I did: enabled debugging, rebooted, navigated to my usb stick, clicked play on the jelly fish file, screen went black and nothing happened, I waited a bit then hit stop, navigated to settings to switch debugging off.

The osmc was a clean install when I got the Vero. I don’t think I imported any settings, pretty sure it was all setup freshly.

Just so I understand, I move the ~/.Kodi directory to anywhere? I’ll lose all settings doing that though?

I’ll see if I can do that later.

I’ve got a second Vero, but not with a 4k TV. I’ll try bringing it through and see if the problem is on it too.