4k hevc stutter through smb

hi,

some advice needed. my vero 4k is connected to my home network. I stream everything from my local win7 pc through samba / smb

everything 1080p related is never a problem, but I of course bought the vero 4k to watch 4k.
first movie I tried, I think I ran against big buffering issues. Audio would suddenly drop out while video continued for a minute or so. Pausing the movie for a few secs fixed it … until a few min later happened again. Audio goes through my receiver. And it’s both with atmos or dts-hd.
Found out here I needed to update my cache settings in advancedsettings.

<cache>
	<memorysize>524880000</memorysize>
	<buffermode>1</buffermode>
</cache>

is what I have now. It’s better, but still get some stutter/ audio drops from time to time (once or twice as opposed to 20 times).
So I presume I need to up my memorysize a bit.
What would be a good size to try to get clean throughput ? I don’t want to just double it … since of course starting a movie will just take longer, and so far 90% of what I watch it still 1080p

I’m quite sure my network is fast enough (I download at 200 Mbps).
Movies I played / tested with so far were all uncompressed.
MI6 ; Ralph 2; Venom; Suicide Squad Hell To Pay.

I’m going to test Aquaman from a HDD connected to the vero to rule out other problems.
Tnx for some suggestions on the cachesize

Hi,

Is this a 4K or 4K +?

The cache is already optimised – so I’m not sure you’ll get much luck there.
Are you connected to WiFi or Ethernet?

Sam

Ethernet
And I presume the 4k+…bought it with the black Friday prOmo

…I’m 33min Into movie now connected with external hdd. Further thanI’ve ever gotten so far… No stutter. So it probably is the streaming

Sam, is the default cache setting still 1, 500MB and 5 for read ahead? Just curious if they’ve changed from when Kodi v17 was introduced.

Hi,

Please provide logs, details can found here:

How to submit a useful support request - General - OSMC

Thanks Tom.

How did you mount the SMB share? Via Kodi or directly via the underlying Linux OS? I believe this has performance benefits over letting Kodi do it.

I came from a chromebox with libreelec… So I just copied my sources. Xml file

Ok, the first thing if do is try mounting this directly in Linux rather with Kodi, there is a guide here;

An alternative but equally good way is to use Autofs, have a look at the instructions and see which you prefer.

OkI’ll give that a go. 2 quick questions before I try that… 1. It has to be IP? It can’t be the server name… Since it’s not a fixed ip. And 2…will the library need to Be reloaded? Causeit’s a big one… And not looking forward to resetting the watched status :slight_smile:

I think hostname should work instead of ip. As for library, I think it needs reloading but you might be able to trick it providing you mount the new library with the same name as the current library, i’m Not 100% sure on this though.

Edit
This seems to explain a supported way of saving the info when you remove the old source and add the new source
https://kodi.wiki/view/HOW-TO:Backup_the_video_library#Moving_the_library

Path substitution is your friend: Path substitution - Official Kodi Wiki

EDIT: I guess path substitution is no longer your friend. Looks like it no longer works in V18 and will not be fixed.

If you bought it on Black Friday 2018, it’ll be a 4K +

OP shouldn’t need to do an fstab mount if he has a 4K + and has Gigabit Ethernet.
Can you go to My OSMC -> Logs and upload a set of all logs and send us the URL so we can check a couple of things?

Cheers

Sam

yes it’s a 4k+ …says so in system.
ok … n00b question … is the logging automatically on ? Meaning I can just do the upload of it ? And it’ll have the info needed (from previous files watched )… or do I first need to turn it on ? And then play a troublesome file until I get the problem … and then upload ?

Nope, we need debug logs. Follow the instructions in the link @Tom_Doyle kindly provided to enable debug mode, play a movie till it stutters, upload the logs and paste the shown url here.

aah yes clear . .sorry … didn’t see his link. Will do that, since logfile I got now is 11Mb
I’ll get back to you

To shrink the size of the logs, just reboot twice.

not sure if I did it right … cause the logfiles were 11Mb again (even after rebooting twice … I can upload it elsewhere if needed). I just used the kodi.log file from the debugging

http://paste.osmc.tv/rivejapidu.vhdl

So I rebooted and played the 4k file which has given me the most trouble so far (MI6).
After about 15 secs, it froze … with message on screen “Source Too Slow For Continuous Playback”.
After a few secs, it continued. The problem then started around the 9min mark. Video would continue to play … audio gets out of sync and then disappears completely. If I pause the movie … wait around 10secs or so and continue … it’s fine again. Depending on the movie … I have to repeat this several times during.

Can it be the HDD on which the files are placed ? I have 1 WD Red in my machine, and 2 WD Blue’s. It just occured to me that all 4k files are on the WD Blue.

EDIT : not the HDD’s … copied the file to the WD Red, same problem
EDIT2 : deleted old dates from the uploadlog … and posted the rest
http://paste.osmc.tv/onikuzazit.md

anyone had time to look at the logs yet ?

Logs created on: 2019-03-22 09:29:33 - (Uptime = 4721098.86)

Uptime is 4.7 million seconds. Hmmm, that’s 54 days.

I’m guessing that permanent logging might be enabled. Does the directory /var/log/journal exist?

no it does not.
not enough info in the other 2 logs ?