4k movie not playing properly


My only 4k movie buffers/stutters when playing and has no audio. I am using the wifi connection to a dedicated 5Ghz signal.

I’ll get more details tonight about the file and debug logs. Is there some other information that I can provide to help troubleshoot the issue?


If using WiFi, you should adapt the buffers through the cache settings.
Over Ethernet, the Cache settings are rather conter-productive.

Does the file play correctly when loaded locally on to the device?

It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC

To get a further understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Where would I adapt the buffers? I guess somewhere in system settings?

Thanks for this, I read the wiki and payed particular attention to the changes for krypton.

So what values should I put for my vero. Do I randomly guess or there is a good suggestion based on the vero hardware?

Add this to your advancesettings.xml file under .kodi/userdata

   <buffermode>1</buffermode> <!-- Default is 1 -->
   <memorysize>90000000</memorysize> <!-- Default is 20971520 bytes or 20 MB -->
   <readfactor>10.0</readfactor> <!-- Default is 1.0 -->

That should improve playback quality.
The best of course is to have Ethernet connected to the device (From experience).

ok thanks! I’ll try it out later this evening and see if it resolve the playback

I think it would be good to see a debug log and MediaInfo first.
I’d connect an Ethernet cable temporarily (and reboot) to see if this improves things.



Ok I can do that first.

What if I load the file on a usb and plug it in directly to the vero to check the playback?

My router is rather far from my tv and I do not have a ethernet cable long enough.

It’s worth knowing the outcome of this scenario, yes.

This is probably the root cause.

For the music playback on my PI’s, without the cache settings, I always have audio-dropouts.
Reason I thought about that.
On the Vero 1, I also had to do that and add a Wireless router to it, as it had better Antennas and better throughput.

Here is the mediainfo, I adjusted the unique id & complete name:


The debug log will follow shortly

Did you try play it via Ethernet yet?

A sample to test locally would be nice.

I will try it from a usb later tonight, I’m a bit busy for the moment with other things.

I would prefer to email the logs to you sam, rather them paste them to be available to everyone.

Where can I email the logs to?

Sam cannot be flooded with individual logs. It’s up to you to sanitize them.

Dam ok…

Just paste it on our pastebin and PM me. I’ll take a look but can’t guarantee I’ll spot anything.

I’d very much recommend testing with Ethernet before proceeding

I pm’d sam the log and he did not see anything.

I tried the video cache suggestion and it also did not work, there was still lots of buffering/stuttering.

Tonight I will copy the file to usb and try playing it directly in the vero. I was really hoping the wifi ac transfer rate would be able to handle the movie, I guess not.

Well it would be able to do so if it is a good connectivity. Check your bandwidth with wavemon and iperf.