4k video playback issue after October update


Ah yes, you did say that. What the October update introduced was:

  • default bitdepth is 10 bit
  • more safeguards to stop vero sending a resolution/bitdepth/colourspace combination that is not supported by the display (as advertised in the EDID)

The first is only doing what would have been done before by the auto HDR setting or setting echo 444,10bit in rc.local.

The second should not be kicking in if your EDID indicates a maxTMDSClock2 and deep colour support. Which it does.

So still scratching my head.


Seem’s like there is an update every day – the last three days the UI told me there was an update (I’m still on the dev channel), and I installed and updated every night.

The updates from the last two days enabled me to play 4k 24fps 10 bit HDR videos right after reboot, without any further commands.

However with today’s update (-133) there is a regression and 4k won’t play after reboot, I have to echo 422now > attr again.

Right now I’m on

Linux vero4k 3.14.29-133-osmc #1 SMP Thu Dec 6 00:30:13 UTC 2018


We haven’t released any stable update since the end of October.

Please upload some logs. I suspect you’re on the staging repository.


Hey folks. Just a heads up about my recent problems which are similar to what OP is getting. I have been running Vero 4K through my Denon receiver which is connected to my Sony 65X900E TV since last year and everything was working fine with 4K HDR/HEVC content until the most recent update. Now I’m getting similar problems as OP (screen going black a few seconds, losing input totally, have to reboot Vero 4K, skippings, etc). I even tried changing my HDMI cable just in case for another high bandwidth one (Amazon Basics). For now I’m using Kodi on my Shield TV (thank Goodness I got an alternative) but hopefully there will be a fix in next release. I can’t run Vero 4K directly from my TV, it has to be through my receiver although if you guys need me to do a test a I could set it up directly to the TV temporarily.

I also confirm that I can usually play 4K HDR after reboot of Vero 4K, but it stops working if I change input on my receiver and come back to Vero 4K input. Sometimes Kodi reverts back to 1080p, so there’s some weird stuff going on.


yes of course I’m on the stretch-devel main to test the new releases and report back on what works with which update and what doesn’t…


Hi all, I thought I let you know that the Amazon basic HDMI cables arrived and solved my issue. Thx for the hint. BTW I’m still on that developer build that you suggested me a few post earlier. How do I get back on the standard release path? ( I already removed the “deb http://apt.osmc.tv stretch-devel main” row, is that enough? Will I get the next standard release?


Yes. As long as you still have deb http://apt.osmc.tv stretch main.


I was curious what the latest is on these 4:2:2 60p / 4:2:0 issues? I have a projector and seem to be having similar issues. Playing a 60p 4k hdr demo video ends up playing at 1080/60p w/ hdr on my Sony projector. I can upload logs but wanted to check on the status first.

(4k 24p hdr plays fine, chromecast ultra 4k/60p hdr plays fine)


We’d need to see a log as things should pretty much be solved by now.



Have you tried setting 4:2:2 with the new option in settings->display?