7.1 Surround sound stopped working


#1

I know you guys did some fantastic work a few months ago to get the 7.1 sound correctly working but it seems to have regressed.

I am now back to the position of 7.1 encoded rips only generating loud clicks in my speakers, as I start or stop the film, but no further sound even though the film is fine visually.

These rips now only work if I change my Vero from a 7.1 set up to 5.1 in the Audio options.

Has anything changed in the past update that could cause this? I have only noticed the problem since the June update but was out the country a lot in the previous month so it could have been earlier.


#2

Someone else had this, then it seemed to go away again by itself. Can you post logs, please?


#3

Please post some logs so we can see how your audio is configured.

Sam


#5

I had mentioned about this issue in the other private conversation. 7.1 LPCM or decoded has no output. 5.1 LPCM works fine.


#6

Try updating:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Sam


#7

Well quite impressed with myself as I managed all that via SSH!

7.1 AAC (Pacific Rim Uprising) does not generate sound (except popping at the start) although 7.1 DTS-MA (Black Panther) has no problem.
Log file https://paste.osmc.tv/ecasutaguh


#8

Thanks for the logs.

17:46:01.481 T:3094070016    INFO: ffmpeg[B86BC300]: [aac] Assuming an incorrectly encoded 7.1 channel layout instead of a spec-compliant 7.1(wide) layout, use -strict 1 to decode according to the specification instead.
17:46:01.493 T:3094070016   DEBUG: ffmpeg[B86BC300]: [aac] element type mismatch 1 != 0

I haven’t seen a lot of 7.1 AAC rips before.
Looks like you may have found a bug.

Can you upload a small sample of the video here so we can reproduce?

Sam


#9

OK - just uploaded a 20 second clip of the original rip. Hopefully I have not changed anything in the process. (I used Handbrake).


#10

Could you also try setting the audio output to Default PCM, please?


#11

Available here (for other testers): https://collab.osmc.tv/apps/files/?dir=/Shared%20Files/Problematic%20Clips&fileid=703


#12

Works for me with audio == PCM. But silent on HDMI


#13

Fantastic - that all works perfectly if I change to PCM output for audio even though I am connected by HDMI.
Out of interest :
When did that change?
What is the HDMI Audio option for now as I used to only get audio and picture if I selected HDMI at that option?


#14

It will be a pesky AESinkALSA change we made. Should be fixable in Kodi – looks like kernel is fine.

Sam


#15

It didn’t, but HDMI has always been a not very good decription of what’s going on under the hood.

Basically, if you select PCM, you get audio on all of HDMI, S/PDIF and analogue. For passthrough, the HDMI output is automatically selected.


#16

Thanks.


#17

Ah yes, that fix for USB audio will have stopped it falling back to default.


#18

When I tested last with kernel 100 (staging) here (output set to HDMI and 7.1) it was working again… Just didn’t work on kernel 98 (which is the current stable branch). Does this behaviour make sense with the findings of others here?


#19

I will also give it a try (will be 8-10 hrs later).


#20

It doesn’t work on 98 and newer kernels if audio is set to HDMI but probably only for some formats such as the AAC example above. It just needs a bit more careful if/then/else in AESinkALSA to make it fall back to the PCM device for LPCM unless another sink (eg USB soundcard) is present.


#21

I only tested with FLAC files and HDMI/7.1 setting. On kernel 98 and 100. With 100 it’s working all the time. With 98 it wasn’t at all.

I stand corrected: Had it set to 5.1 since testing with 98 initially and was intelligent enough not to check this again… Although I stated that I did. Sry! HDMI/7.1 setting only gives silence (except the plop at start and stop of playback) when playing back a 7.1 FLAC file here.