A few Q's about: Access SMB shares from Kodi


I have googled aloooot to find a solution, but no i didn’t. Watched some videos on youtube also…
Just don’t get it…

Also i saw this thread: Accessing a Windows 8.1 smb share
But nope, not working.

Ok, here we go:
I got two Pi 2’s, one of them still works and can access the shares on my Win 8.1. The other one got screwed up when i was trying to get iStream to work and it ended up with a clean install of OSMC, so now i can’t add the shares back.
I find the WORKGROUP and i can see all the folders shared, but when i try to add them i have to type in login/pass, so i typed them in but it seems like it’s the wrong login and/or password!?

Is something messed up with Kodi/OSMC or is it really my login that’s wrong? If so, how do i check what login and password i have?

Sorry, but i’m extremely tired… hope this makes any sense =(


Hi there!


Thanks! :+1::laughing::point_up:

1 Like

That guide tells me to create a homegroup (Windows 7 method, that’s supposed to work on 8.1 also), and that has never been needed for me before (and still works on my other raspberry pi 2 with OSMC). The Windows 8.1 method is not working either. =/

What login/pass are you typing in here?
Also you mentioned one of your two Pi’s is still working. So let’s compare any package differences between the two installations. Post the URL of dpkg -l | paste-log from each machine

1 Like

It’s been a long time since i shared these directorys, but i’m guessing it’s either passwordprotected shares OR any adminusers login/pass from that 8.1-machine? I don’t know where on the Win 8.1 computer i should check to see this… :open_mouth: -noob-

Post the URL of… ok, how do i do this? :smiley:
Both Pi’s have the latest OSMC, with the same addons.

Update: I have installed Kodi on my androidphone and tried to access the shares, but i can’t get thru the login there either…

Login into OSMC with ssh and execute the commands i posted.
Details how to access OSMC via command line locally or via ssh can be found here: Accessing the command line - General - OSMC

While I believe they are the same something is still odd if one work and one doesn’t.

Well if you want to connect you at least should know how to connect to it :slightly_smiling:

1 Like

Well, the strange thing is that i have done this a million times before! Connected to my shares… but now it’s not working, because i have to type in a password. I have (had!?) a simple login, like XBMC / XBMC on all shares. Something has changed, without my knowledge. I don’t even know how to change this password in windows? =(

Is it possible to just copy a file from the working Pi that holds the shares and passwords to the non-working one?
Damn, i really feel like grandma now… sorry

OK, now i have removed ALL shared folders. I followed a few guides (even the one linked above), and i can’t get it to work.

I find the WORKGROUP, click it, and see my computer, click that one, and then i get this:

I have tried to share it to a temporary user called admin (with the same password). When i got to this “Lock preferences for smb” i wrote user and password admin/admin
I have also tried to use my windows login (mail and password). Tried to share with EVERYONE, full permissions, but i can’t get pass this login box! GAH =(

Am not at my PC, but I think enabling guest and or anonymous on the PC shares was the trick

Hey guys just found out the solution to connect to win8.1 smb share: you need to add a local user!

Hover your mouse on top right corner of screen. Hit settings then at the bottom “modify computer settings” or wtv it’s called my computer is french.

Click “Accounts”>“Other accounts”>“Add account”

Next find “Connect without a Microsoft account” and click it. Hit “Local account” and enter desired info and Voila!

Use that account to connect your RPi with your PC!

1 Like

name osmc
pword osmc

works for me, evidently it’s asking for the Samba credentials not the computer credentials.