Accessing a Windows 8.1 smb share

I have a problem with a smb share, which is located on my Windows 8.1 PC.
Permissions are set to everyone, read only without any password.

When I try to access it via osmc it always asks for credentials. I tried to leave it blank and I tried it with my Windows Live ID (email/password). But no success at all.

Am I missing something? I’d appreciate any help.

first name / password

or whatever you added as firstname if its a nickname or whatever

1 Like

“Everyone” does not mean unrestricted access rights.

It means all valid user accounts on the Windows machine can access the share.

So you still need to provide valid credentials. Either use your username/password that you log into windows with, create another account on the Windows PC just for OSMC to log into, or enable the guest account in windows (off by default) and use guest for the username and a blank password.

There are some security implications to enabling the guest account in windows which is why it is off by default.

1 Like

Thank you guys! Tried it with @Toast advice and it just worked!

I’ve been looking for this answer for days. @Toast is correct. I was able to connect to the SMB hosted by my Windows PC from an android phone client, but not from my Pi. Whatever reason, it seems OSMC on Pi would not take symbols in the username, even though symbols work on other clients. This will get around that problem.