Access HDD connected to Pi wirelessly with laptop

I have been searching and trying for the last couple hours for a way to add movies to my Media center hdd without having to open my enclosure, disconnect the hdd from the pi, and reconnect to my laptop. And to be able to possibly stream movies from the pi hdd to my laptop if I am away from home or just want to watch on my laptop for whatever reason. I have tried to set up samba (from what I understand this will do all that I want) but it never shows up in my networks, I have tried searching the ip address of the pi as well to no avail. If someone could provide some assistance it would be greatly appreciated

Have you installed samba from the App Store? Which OS are you using on your Notebook?

The best way would be using a VPN which could be openvpn

Im on windows 10 and yes I did install it from the app store. also streaming the movies while im away is only a secondary objective, but once i get samba working i will look into VPN.

Ok, to troubleshoot it would be the easiest if you could login to the Pi with SSH.
Suggest
you install putty on your windows machine and the login OSMC
information how to access OSMC via command line locally or via ssh can
be found here: https://osmc.tv/wiki/general/accessing-the-command-line/35

After your login run:
sudo systemctl status samba to see the status of samba (should show “Active”)

If the previous test is successfull then on your Windows PC go to command line and run
net view <IP of OSMC>

okay after running sudo systemctl status samba it says “Active: active (exited) since sat 2016-05-07 22:31:03 MDT; 2min 46s ago”

and after net view command I get error 53

On your notebook have you defined your LAN as “private” and enabled file sharing?

On OSMC what does net share gives you.

yes I have it both set up as private and have enabled file sharing.

net share first asks for the password and then shows:
osmc
IPC$
MEDIA HDD

Which means all is Ok on OSMC side.
Definitely an issue on your Windows 10.

Do you have and Android phone to test? Install X-plore and try to access smb

my first few scans for servers with X-plore (nice app btw) showed me nothing, then I got lucky, it showed up and I was able to connect to the pi, albeit it only lasted 2 min or so. while connected it showed me a osmc folder and a HDD folder but i was unable to open them and view their contents (possibly due to the fact I have a shitty phone or a limitation of the app). then it said the connection timed out and would no longer show me the folders. later scans came up with nothing. My ssh connection was timing out before it even connected to the pi so I did all those commands locally, perhaps these issues are related?

Definitely, how are you connected? Wireless or Ethernet?

I am connecting wirelessly but I havent had any trouble connecting to the internet, like downloading updates ect…

Check your wireless connection with wavemon, sudo apt-get install wavemon
And then the bandwidth between notebook and OSMC with iperf, sudo apt-get install iperf3

okay I ran wavemon and from what i could tell it everything looked fine I took a picture just in case I am totally wrong.


I then ran iperf3 -s on the pi and iperf3.exe -c <IP Address> im not sure if i ran iperf3 correctly or not. On my laptop it said connection timed out and there was and still is no response from the pi.

First 6 MBit/s doesn’t look very healthy as a wireless connection.

And if you have connection problems from your notebook to the Pi you really first have to sort out your LAN.
Try first with Ethernet cable to see if it makes a difference.

so the commands I issued for iperf3 to connect pi and laptop were correct?

I’m sorry but I am still rather new to this stuff. Unfortunately I have no way to connect via Ethernet at the moment. Could my 6MBit/s be caused by a poor wifi dongle or is that more of a router/modem problem. lastly what would be involved in sorting out my LAN problems? Also Thank you for the time and effort you’ve put into helping me.

Well wireless can be tricky. As a first start if you have a Android phone you could use wifi analyser for overlapping channels and signal strength in different areas.

But you generally even with 6 MBit should be able to connect.
What are the IP address of your notebook and your OSMC? Can you ping each other?

when I use wifi analyser is see six different options under my internet name. each with a slightly different string of numbers and letters behind it. Some kind of address Im sure. one with (50:60:28:2e:1e:80) and another with (50:60:28:2d:04:80) some are channel 11 and others are 6. If my computer and osmc are connected to a different addresses under the same SSID. could that be whats causing all the headache?

That are different MAC addresses. Do you have multiple Access Points? It’s really hard to do a remote trouble shooting without knowing how your LAN is setup.
What about the IP addresses on the different devices? Are they in the same segment? Do they use same DHCP server?

yes there are several different access points. As for the IP addresses Im not sure what “in the same segment” means. My computer IP is 10.50.214.227 and my pi is 10.50.212.41 i do not know whether or not they use the same DHCP server.

i just tried to ping the pi and i managed to get through, even though i haven’t really done anything other than troubleshoot. Since my ping made it through i decided to try sshing and it connected despite refusing connections earlier today and yesterday. And i just now tried to connect via samba and it worked.

I have no idea why nothing was working before but now all of a sudden it all works, albeit slowly.

So are you managing that LAN or someone else is doing that? To be honest all of this is basic LAN troubleshooting and not related to OSMC.
The 6Mbit connection you saw on Wavemon is a a good indication that you have a wireless problem and it would be clear that with that bandwidth samba would be struggeling