Adding Repos

Hi Sam and guys,

I’m having issues trying to add a repo…

Having to add a repo from the kodi systems settings / File Manager
The wanted repo is in the list now, but when I return back to the Kodi Home page Add-Ons page, the repo doesn’t show when installing from repository is selected…

I’m getting buffering issues and trying to use a fix from top tutorials…

Any words of advice how I can add a repo the old Kodi way or get this working?

Any help would be appreciated…

Thanks all…

:slight_smile:

I’m not sure how adding a repo would help you with buffering, so maybe a little more information would help.

I’m trying to fix issues with buffering by installing an add on that allows me to change the cache sizes of Kodi…

Cache sizing on the Vero4K is optimized out of the box

I am running a new Qnap NAS, and trying to stream via wifi network… very very slow with long pauses in buffering…

So trying to fix it…

Buffering only can help with a fluctuation in bandwidth not with constant under performance.
As I wrote Buffer settings on Vero4k are optimized already for the memory that the 4k has.

Suggest to check your network performance with iperf3 and compare that with the required bandwidth of the file you want to play.
Depending on the file sharing protocol you use you might also be able to improve on that.

Thanks fzinken,

But all my files are standard non 4K files. Approx size around 700 mb - 1.5 Gb mkv files…

I am not a tech guy to say so I’m not sure about much. But it seems it should work a little better. I bought 4 boxes and am generally been happy with a hard drive connected to the 4K, but am increasingly getting frustrated after trying to place my media on a NAS or the like.

I have no idea what iperf3 is or what that means…

Sorry…

I bought these units because of simplicity. Had Kodi Raspberries since #1 and thought this was going to be a foolproof out of the box solution…

It’s a tool to measure your network bandwidth. Check out this how to

You might need to first read up about the command line
Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

It is a foolproof out of the box solution but it can not magically overcome wifi performance issues

1 Like

Thank you mate.

I’m not complaining mate, no buyers remorse. It’s just I never have much time to sit and tinker too much and learn new languages.

I will take a look at the iperf thing and the links you suggested.

Thank you for your time.

Sorry fzinken,

Can I ask you please…?

Would you know which version of iperf3 should I download for a Qnap NAS TS…

Maybe another follow up question…

How does one install on a NAS if not installing from within the NAS App Center…?

I am not a QNAP expert but Google gave me this
https://forum.qnap.com/viewtopic.php?t=140883

Alternatively you can also install iperf3 on your PC to test PC <-> Vero as a starting point.

1 Like

Thanks mate.

I got it installed via putty (I think on the 4K.

I will look at those links…

Thanks heaps again…

Fzinken here are my results…

Does that look like it would be a problem with my network?

image

So I have no idea why i would be getting poor performance whilst trying to watch a movie…

Any ideas ?

Well an average of 11 Mbit is surely quite at the edge even for 1080p.

I assume you use 2.4Ghz can you use 5Ghz?
If you only have 2.4Ghz maybe try a different Channel?

Yes I do use 2.4 Ghz I don’t have 5.0 GHz

I have tried to use another channel but the Vero couldnt connect.

Is there a way to manually select the channel in the Vero?

Which Channel did you tried?

From memory 12

It was a few weeks ago

The Vero might not have picked up the right CRDA and therefore block Channel 12.
Suggest you use 1, 6 or 11 and maybe also first check with an APP on your phone (network scanner) which one is the most occupied one.

Ok will do that…

Thanks again fzinken

BTW, one topic we haven’t answered which Network Protocol are you using to access the Qnap and are you using direct access from Kodi or FSTAB mounts?