Adding Repos

Ok will do that…

Thanks again fzinken

BTW, one topic we haven’t answered which Network Protocol are you using to access the Qnap and are you using direct access from Kodi or FSTAB mounts?

SMB because I can’t connect via NFS, even though it is enabled like SMB on the folder share on the QNAP NAS

Yes I have tried to unenable and re-enable it to no avail.

Kodi just can’t connect … I can add the IP address but then I cannot select the folder. Although the correct folder names and folders are in the list

Just via Kodi built-in function or via fstab mounts? As your 11 Mbit is very much at the edge you might want to use every bit of improvement by e.g. moving it to fstab mounts.

I guess thru kodi…

Fstab mounts…?

You know I’m going to ask you ,ore questions… haha

How can I add thru Kodi fstab mounts…?

Well two possible options:

After you have mounted them via fstab or autofs you can add in Kodi via `root filesystem"

Which option would you recommend… for my level of tech?

Easiest more fool tolerant way?

Personally I think you should be able to have success with this

Thank you again fzinken.

Could I rack your knowledge

If I edit the SMB CONFIG like Autofs tutorial is describing, will adding also the NFS Confic will that cause conflict?

Can I add them both now and then later decide which one is the preference or which is working faster?

Sure you can use either or as long as you use different local folders for each of them!
While I understood you said you had issues with NFS?

I did, have issues with NFS, I was thinking this may have fixed those issues.

Just get the sense people say nfs is a faster more stable protocol… I wish I could have connected that way

Well run sudo showmount -e <IP.OF.NAS> on the Vero and we know if your NAS is configured correct and then autofs can solve your issues.

Well it is the “native” protocol for Linux and therefore the most performant.

I have a folder list shown in Putty inducating the correct folders…

So hopefully adding this NFS will fix Kodi access…

Blockquote

Now I’m confused…

I think I installed autofs using putty…

But the minute I try to … edit [sudo nano /etc/auto.master]

I’m stuck with a new type of editor and i can’t save the file. The command keys don’t seem to work and I’m not sure if I’m writing or saving to the file.

The same with the nfs master…

I’m using those commands that were in the tutorial but logged in in putty to … is that correct?

I can add those changes required whilst logged in to my Vero thru putty?

Sorry, I did tell you in tech deficient

To save you use ctrl-y to exit ctrl-x
More info here
http://www.cheat-sheets.org/saved-copy/Nano_Cheat_Sheet.pdf

You added a source location. You now must install from zip file to acquire the repo before you can install from repo.

Hi fzinken,

Well I’ve been trying to get the autofs working… still no joy…

I’ve followed along even copied and pasted the commands and still getting no luck.

I will try with the fstab version now…

Hopefully it will be more fruitful than with autofs for me…

Wait, I think you would not be much more successful. Lets review this first.

When we use <XYZ> this normally means the whole thing need to be replaced with your specific information. So the right command would for example be showmount -e 192.168.1.180
That means also for all the other you need to remove the < and >

My suggestions run following commands a provide the shown URL (copy/paste works from Putty
showmount -e 192.168.1.180 | paste-log
cat /etc/auto.master | paste-log
cat /etc/auto.smb.shares | paste-log

Ok mate thanks,

I will read your instructions a couple of times then try and execute…

Please be patient…

Thank you sir for your guidance thus far…