After latest updates HifiBerry Digi+ stop working

Hi there,

After the latest updates my HifiBerry Digi+ stop working.

My default card is now bcm2835.

osmc@osmc:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HifiBerry Digi HiFi wm8804-spdif-0
Subdevices: 1/1
Subdevice #0: subdevice #0

Is there a way to undo this?

Please, let me know

1 Like

I’ve just found that there is a topic open about this issue on the HifiBerry forums.

A search would have shown you this: January update now iqaudio dac not working?

1 Like

Same problem with hifiberry dac+ i have the same output of hbbs but my card1 is hifiberry dac + try to reconfigure but nothing work.Yesterday all working fine… (i found also my video settings on Desktop instead of 1280x1024).The solution is written in other forums…Add dtparam=audio=off to your config.txt file. Reboot and all work!! Maybe you need to re-set audio output in settings system audio output.

1 Like

Indeed, I should have searched more. To my defense, I was doing it on my Android.

Thanks, it is working.