After october update HIFIberry Digi doesn't function

Hi @sam_nazarko! Is there any news?

Not yet – no.

With the new update the issue is corrected?

No - there is no new kernel yet. This thread will be updated when there is something to test.

1 Like

It worked for me. Thanks.

Hi

Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

1 Like

Could you try it please?
@bengio and @tiroy
Thanks
Jan

Ok @sam_nazarko and @JanS

Excuse me…which is the command to edit the file /etc/apt/sources.list ?

Thanks

sudo nano /etc/apt/sources.list

hi
i had osmc october 2019 2019.10-1
and now i’ve got osmc March 2020 2020.03-1.

in System/Audio i’ve chosed Alsa: snd_rpi_hifiberry_digi,S/PDIF in Audio output device
i have allowed passthrough and i’ve chosed "ALSA: snd_rpi_hifiberry_digi,S/PDIF in Passthrough device and i’ve allowed AC3 and DTS.

The audio now works! Great Job!

But… i think that a problem of my Onkyo audio amplifier…when start film, before, i have to turn off/on amplifer to listen the sound of film. Or is it a not correct setting in System Audio in OSMC?

thanks
Bye

The explanation of your problem is not clear. Can you elaborate please.

ok.
The audio card of RaspPi is connected by digital cable to Onkyo amplifer.
When i play film on OSMC I don’t hear any sound THEREFORE I turn off and turn on the onkyo amplifer and after i can hear the sound of the film.
Thanks
Bye

can you post logs please

In the settingsmenu, under system-audio there is an option “Keep audio device alive”. This is set to 1 minute by default, but with some receivers it helps to set it to Off or Always (you have to experiment with it a bit).

https://kodi.wiki/view/Settings/System/Audio

1 Like

Great @Chris_Hogevonder !!

with “Keep audio device alive” set to OFF (before it was set to Always) i can hear the sound of the film immediatly.

thanks a lot!
Bye

Hi all,

I have just applied the new commit from devel branch and I can confirm all is ok now. Hifiberry
Great job, thank you guys :slight_smile:
Cheers!

Thanks all !
Hifiberry is ok now.

Im trying to get a hifiberry digi working on June 2020 version OSMC on raspberry 3. I have also applied the kernel fix referenced here.

I have set up the digi overlay in My OSMC,. and set the default hiberry alsa option in system settings.

I have tried with audio passthrough set on and off.

Here are the symptoms.

the “lock” light never comes on the DAC.

there is no sound.

I have tried with movies and mp3 music.

Here is some extra information.

At the moment, I tell OSMC to send the audio to HDMI. I have installed a breakout box between the PI and the TV. This gives me an sp/dif toslink which I feed to my DAC. This set up works perfect for both music and movies in all file formats (that I have tried)

My DAC is 1990’s old. It doesn’t appear to work with more than 48k. It doubt it recognises multi-channel video output. Thats why I tried without passthrough off as well. Im pretty sure the DAC wants CD quality stereo.

The music is stored on OMV NAS. Music from the same NAS is read and played ok by volumio, so I dont think its a source file problem. OSMC will play music and movies OK wth sound when I select HDMI audio output.

My suspicion is I have more than one problem, so plenty of scope for setting off down the wrong route. Is there a way to force the hifiberry to 48 or 44.1 only?

I get exactly the same problems when running libreelec latest version

Any help gratefully received.

Have you tried going into Kodi’s settings>system>audio> and setting
number of channels>2
output configuration>fixed
limit sampling rate>48khz

Thank you for the tip.
I did as you suggested. When I set configuration fixed, I could no longer set the number of channels. I set the sampling rate to 48k.

I tried with resample rate on low, and medium. I rebooted after each fix.

I’m disappointed neither worked. It looked like the sort of fix that might work.

There is no sound now when I try listening to my breakout box toslink, so I suspect the PI is definitely sending the sound to the hifiberry.

Is it possible to run amixer on an osmc system?