After october update HIFIberry Digi doesn't function

Are there any updates?

At this time I’m holding kernel version 4.14.78-4-osmc, but I would like to update again…

Unfortunately I don’t have any HifiBerry hardware to test
I will update the kernel again in a couple of weeks, which will hopefully resolve the issue nonetheless.


1 Like


For your information I had a similar issue after October update. Hifiberry card was shown as an output audio device but not in passthrough. I followed the instructions from HiFiBerry Digi under kernel 4.19.x working without patching Kodi source? and it worked fine to me.

Basically you need to add the card usr/share/alsa/cards/RPi-WM8804.conf ( that is gone after upgrade. Once it is added, reboot raspberry and Hifiberry will be available in passthrough.

I hope next OSMC update will keep this config card file!



Hi. With january update has the problem solved?

To be honest, I’ve stopped using OSMC at this moment and switched to RetroPie with Kodi, where this isn’t a problem at all and which can be used with a RPi 4 in beta-release.

Hi @sam_nazarko,
Has It solved with the last kernel of january update?

No - but I will produce a new kernel this week and update this thread.



Hi @sam_nazarko! Is there any news?

Not yet – no.

With the new update the issue is corrected?

No - there is no new kernel yet. This thread will be updated when there is something to test.

1 Like

It worked for me. Thanks.


Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

1 Like

Could you try it please?
@bengio and @tiroy

Ok @sam_nazarko and @JanS

Excuse me…which is the command to edit the file /etc/apt/sources.list ?


sudo nano /etc/apt/sources.list

i had osmc october 2019 2019.10-1
and now i’ve got osmc March 2020 2020.03-1.

in System/Audio i’ve chosed Alsa: snd_rpi_hifiberry_digi,S/PDIF in Audio output device
i have allowed passthrough and i’ve chosed "ALSA: snd_rpi_hifiberry_digi,S/PDIF in Passthrough device and i’ve allowed AC3 and DTS.

The audio now works! Great Job!

But… i think that a problem of my Onkyo audio amplifier…when start film, before, i have to turn off/on amplifer to listen the sound of film. Or is it a not correct setting in System Audio in OSMC?


The explanation of your problem is not clear. Can you elaborate please.

The audio card of RaspPi is connected by digital cable to Onkyo amplifer.
When i play film on OSMC I don’t hear any sound THEREFORE I turn off and turn on the onkyo amplifer and after i can hear the sound of the film.

can you post logs please