After october update HIFIberry Digi doesn't function

In the settingsmenu, under system-audio there is an option “Keep audio device alive”. This is set to 1 minute by default, but with some receivers it helps to set it to Off or Always (you have to experiment with it a bit).

1 Like

Great @Chris_Hogevonder !!

with “Keep audio device alive” set to OFF (before it was set to Always) i can hear the sound of the film immediatly.

thanks a lot!

Hi all,

I have just applied the new commit from devel branch and I can confirm all is ok now. Hifiberry
Great job, thank you guys :slight_smile:

Thanks all !
Hifiberry is ok now.

Im trying to get a hifiberry digi working on June 2020 version OSMC on raspberry 3. I have also applied the kernel fix referenced here.

I have set up the digi overlay in My OSMC,. and set the default hiberry alsa option in system settings.

I have tried with audio passthrough set on and off.

Here are the symptoms.

the “lock” light never comes on the DAC.

there is no sound.

I have tried with movies and mp3 music.

Here is some extra information.

At the moment, I tell OSMC to send the audio to HDMI. I have installed a breakout box between the PI and the TV. This gives me an sp/dif toslink which I feed to my DAC. This set up works perfect for both music and movies in all file formats (that I have tried)

My DAC is 1990’s old. It doesn’t appear to work with more than 48k. It doubt it recognises multi-channel video output. Thats why I tried without passthrough off as well. Im pretty sure the DAC wants CD quality stereo.

The music is stored on OMV NAS. Music from the same NAS is read and played ok by volumio, so I dont think its a source file problem. OSMC will play music and movies OK wth sound when I select HDMI audio output.

My suspicion is I have more than one problem, so plenty of scope for setting off down the wrong route. Is there a way to force the hifiberry to 48 or 44.1 only?

I get exactly the same problems when running libreelec latest version

Any help gratefully received.

Have you tried going into Kodi’s settings>system>audio> and setting
number of channels>2
output configuration>fixed
limit sampling rate>48khz

Thank you for the tip.
I did as you suggested. When I set configuration fixed, I could no longer set the number of channels. I set the sampling rate to 48k.

I tried with resample rate on low, and medium. I rebooted after each fix.

I’m disappointed neither worked. It looked like the sort of fix that might work.

There is no sound now when I try listening to my breakout box toslink, so I suspect the PI is definitely sending the sound to the hifiberry.

Is it possible to run amixer on an osmc system?

I osmc@bigtv:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HifiBerry Digi HiFi wm8804-spdif-0 [HifiBerry Digi HiFi wm8804-spdif-0]
Subdevices: 0/1
Subdevice #0: subdevice #0

I had to install alsa-utils to get these. looks like the driver got installed ok?
i also set the overlay to …digi and …digi-overlay. Neither worked

There is the same problem again after november update


You have a HIFIberry Digi+ ?

I don’t have any HifiBerry hardware to test or reproduce this.

You could wait for the next kernel which will come out in a couple of days.

My HiFiBerry DAC also no longer working after Nov 2020 update. Not even a selection option in System Settings Audio Device for HiFiBerry. Just HDMI and analogue.

Sorry - without the hardware and without logs, I can’t help.

My problem was solved after a second update came through. HiFiBerry operational :slight_smile:

Hi. I have another time the Same problem. Buy i have noticed Also that : if the film Is played for First Time the audio Is not present but if the film Is already seen for example for 10 minutes and i resume from 10 minutes the audio Is present. It Is vert strange… Thanks

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


here is the log

news of 22:11
if in Setting/System/Audio i NOT allow passthrough the audio is present immidiatly but not in DolbyDigital 5,1 but in sample dolby pro logic. if I allow passthrough the audio is not present and i have to turn off and turn on the Amplifer to hear the audio track