AirPlay Not working

AirPlay Not working osmc alpha 4.

We will need a log.

Working for me including video but the video is very blocky. I am using really good AC wifi with a strong signal so not sure if an OSMC or an Apple issue. Watching a video on youtube of someone showing OSMC on an RPi2 their Airplay was really good?

Well i get error "This AirPlay device is not compatible with this software " and thats all. I am on Yosemite and using LAN cable.

1 Like

Do i need to update anything ?

I have the same pankajet’s problem with my mac on Yosemite. Moreover with my iPhone 6 on iOS 8 i can use AirPlay for Audio but no for video. Can you tell me why?

Yosemite is broken for AP I believe

Video: you could be playing a variety of sources. Most of them are probably DRM’d.

I’m also trying to AirPlay from my Mac (Yosemite 10.10.3) and iPhone (iOS 8.3 (12F70)). I wasn’t able to play video. I’d like to be able to stream music (Spotify) and video (Netflx and Amazon Prime) from my iPhone / iPad. Any chance this will be possible?


I’m pretty sure Netflix and prime require DRM, therefore, not possible.

Audio works great on Yosemite 10.13.3 - but can’t send screen to OSMC RC3 on Raspberry PI 2

“Send screen” would be mirroring? Mirroring has never worked.

I have just updated to the last version of OSMC (June 2015.06-1). After reboot AirPlay stopped being visible and has disappeared from all my iOS devices.
It could be also caused by renaming of the Raspberry Pi hostname. i have edited /etc/hostname and /etc/hosts before the update.

so what i have already tried is to to to settings -> services -> turn AirPlay off and on. But no luck. i cannot see Kodi in the list of AirPlay gadgets on my iPhone.

How can i debug this? what logfile is needed?

Please have a look at the pinned posts at the top of this Help and Support forum.

Problem has fixed itself after turning on Debug and reboot :slight_smile:

got the same problem with final release

It is strange, because from iTunes works perfectly video and audio, but not from the status bar AirPlay icon

“This AirPlay device is not compatible with this software”

Yosemite 10.10.4 latest release of OSMC

One thing to be aware of is that Kodi needs to advertise itself as capable of mirroring despite the fact it doesn’t support it.

Yes, and this is a setting in Kodi


I thought airplay was not working for me 18July2015 on “Stable Release”
but it depended on what I try to play.

Youtube videos are not working for me but this non-Youtube video proves it does work: Lightroom -Ten Things Beginners Want To Know

OSMC 2015-06-1
Kernel: Linux 3.18.13-1-osmc
Platform: Raspberry Pi B+
OSMC->Settings->Services->Airplay->Enabled (no pw mode)
(If don’t see Airplay in Services menu: click Basic to go to Standard, Advanced, or Expert mode)

From iPhone5 and iPad Mini: Swiping up, Airplay will show and green check mark the Kodi(osmc) line, but nothing appears on my OSMC for normal Safari pages or YouTube App playing.

Going to the above link and pressing play - starts right up on OSMC/TV

iOS apps that enable DRM won’t work with Airplay.
This includes the YouTube app which won’t work.
YouTube through Sarafi doesn’t enabled DRM and should work.