Alternatives to the remote

The battery of my remote is empty and it looks like I have to order a new one online. Is there any way I can control the Vero 4K in the meantime? Does it support a keyboard or mouse for example?

Keyboard - yes. Mouse maybe.

The OSMC remote’s battery is a pretty common type, though. Have a look in your local supermarket.

Also, try using your TV’s remote through CEC.

Neat, thanks for the quick reply. I only have one keyboard so I didn’t wanna unplug for no reason.

If CEC doesn’t work, there’s also a web interface, so you can also control it via a browser.

If you got web interface enabled in kodi you can also use an kodi controll app on your phone, like Kore or Yatse on android, dont know what it’s named on IOS.

On iOS there is an official remote app. It’s called “Official Kodi Remote”. It works really well!

I have a miniature USB keyboard with a built-in trackball. Works perfectly, apart from the “multimedia” keys.

Sorry to bump an old thread but it turns out the battery wasn’t dead, as even with two different replacement batteries my remote continues not to work.

I’ve been using my TVs remote via CEC for the past few months but it continuous to be a nuisance. Since I noticed that the remote is at least somewhat functional (the blue led on the remote lights up when I press buttons), I tried to pair it again by holding down home+ok at the same time, sadly to no avail.

Anyone have an idea what might be the issue or what else I could try? I can’t imagine it’s completely broken as my unit isn’t that old, just a little over a year.

Did you try with new batteries?
Do you see a blue light when you press a button?

Yes, I tried two different brand new batteries in fact. I see a blue light on the remote on the remote, as I said in my post, I do not see one on the dongle in case that’s what youre referring to.

Did you try re-pairing the remote?
Hold Home and OK

Edit: looks like you did.

Try uploading a log. It should show if the dongle is connected.

I’ve PM’ed you a link to the log file, let me know if it has the required information.

Did you have a chance yet to look at the log I sent you?

No — can you put the URL here?


I was hoping to avoid posting my log publicly but sure, here you go:

The USB does not seem to be connected / recognised.
Can you take a photo of your dongle and confirm if the remote has volume buttons?


Here is the requested photo:

I assume you meant a photo of the dongle unplugged from the Vero?

The dongle needs to be plugged in for it to work; but it looks like it’s not being recognised from your logs.

If you contact we can send you a new dongle.


@Snorefingers Is there any chance that the dongle could be exchanged with the one from another device?
I’ve a Rii mini keyboard which has an USB Wifi dongle looking exact the same like the OSMC dongle except a very small writing on one side.

I was wondering if you have any sort of status update for me regarding the dongle replacement? I contact support as you instructed on April 10th but have not heard back via email or received a new dongle since.