Android dual boot now available for Vero 2

Hi everyone

After a long wait, dual boot Android for Vero 2 is now available. The official blog post is here:

https://osmc.tv/2016/08/android-dual-boot-lands-for-vero2/

Overview

This has certainly taken longer than expected, but I have finally managed to get Android running off an SD card, as originally intended. We have had some Android builds for some time but they all ran off the internal NAND and not the SD card. The benefit of being able to run Android off the SD card is dual-boot functionality. This allows users to run Android alongside their OSMC installation without losing their existing setup.

Our initial Android is based on 4.4 KitKat. There are newer Android builds available, but this seems to offer the best functionality from the SoC vendor and most applications run on this version of Android.

You will need an SD card with a minimum of 8GB space. For the best performance, you should consider a fast SD card: the OS runs off the SD card, so it is important it delivers good performance.

When you first boot your system, it will still load OSMC. You can learn about how to switch between OSMC and Android on the Wiki page. In the next OSMC update, I’ll add an option to Kodi to reboot to Android without having to do this manually via SSH.

Launcher and remote compatibility

I have chosen to use the Nova Launcher as the default launcher as it seemed to be a nice launcher. If the community have some other suggestions then I am open to changing this. I am keen to find a launcher that works with a remote well, but this may be challenging. There are some – but they don’t look very good. For some tasks such as web browsing, I found it necessary to use a mouse and keyboard.

Thanks for your patience

I understand that this should have been available some time ago. At the time when we released the Vero 2, we had NAND builds running fine, and I had (perhaps naively) assumed that an SD card release would not be hard to achieve. Certainly, I am sure that some of you are aware that on Linux this just involves tweaking /etc/fstab and the root= /proc/cmdline argument. Android is quite different in that regard, and there were a number of issues that had to be resolved to get SD card working reliably.

Nonetheless, I apologise that this took longer than expected, and that some of you did not have the dual-boot Android functionality and were disappointed. Android is a new platform for me and this is not an environment that we have really worked with before.

We will be working on Android in the future, and I will be keeping a close eye on the interest that this gets.

Wrap up

The first boot will take a few minutes as Android is set up for the first time. This is our first public build, so I’d appreciate your feedback and suggestions.

3 Likes

Thank you Sam and everyone who has worked on this.

I just receive “Download failed” when trying to download Android 2016-07 :-/ (installer on OS X 10.11.6)

Try downloading the image manually and imaging it to an SD card.

You could also post the OS X log. I haven’t tested the installer with the image. There will likely be some issues if you try and preseed WiFi or network settings, as Android doesn’t work this way.

Here’s the log:

So. Aug. 21 17:19:47 2016 Downloading http://mirror.bytemark.co.uk/osmc/osmc/download/installers/diskimages/OSMC_TGT_VERO2_ANDROID_20160821.img.gz
So. Aug. 21 17:19:49 2016 Error occured downloading file:
So. Aug. 21 17:19:49 2016 Error downloading http://mirror.bytemark.co.uk/osmc/osmc/download/installers/diskimages/OSMC_TGT_VERO2_ANDROID_20160821.img.gz - server replied: Not Found

Edit: downloading manually from the server

cant get the installer to download the image but have managed to download the .img manually and seems to work, maybe a link in the disk image section on the download page would be helpful but thanks so far!

Hi

This just means some of the mirrors haven’t synchronised yet. Just grab it from osmc.tv/download.

There is one at https://osmc.tv/download under Vero 2.

Edit: I made a typo, which caused some problems with the Downloads. If you can’t find links or get a download, don’t worry – things should correct themselves in about an hour.

Sam

1 Like

I installed Android and started it up. But I don’t understand how to control it. With the Vero remote I can only access the dock. And when I press the drawer button I can’t choose any apps because the direction buttons doesn’t work in the drawer.

Can somebody explain what I should do?

See the initial post. We are using the Nova Launcher which may not be adapted for remote controls. I am open to other launcher suggestions.

Even in my testing with other launchers which you can control with a remote, most tasks like web browsing will require a mouse

Yeah, seems like mouse and keyboard is the only option right now.

I’ve gotten Spotify to work by downloading it through the browser from apkmirror. I tried the same thing with Google Play Store, but it won’t start. I’ve installed Google Play Services, but it didn’t help. Any suggestions?

I’m also wondering how to add my Google account?

Be careful when installing this. I ended up with an unintentional fresh install of OSMC, wiping out all settings and configurations I have done :angry:

Downloaded the disc image for Vero 2 Android, and used the OSMC installer to put it on an SD card. Must have done something wrong, not sure what.

Tried to put disk image directly on the SD card with a disk imaging software, but did´t seem to work either, it just boots up into (the freshly installed) OSMC.

That sucks :confused:

No offense but are you sure you didn’t accidentally choose an osmc image in the drop down menu?
@sam_nazarko Is it still the case that our osmc install on the nand gets wiped and reinstalled if one pops in an sdcard with osmc image on it? …Without any warning or hint? …
I remember getting this information by chance…

@trohn_javolta probably something like that. I choose Vero2 in the drop down meny, then I selected a custom image (the Android image), but somehow it must have downloaded the normal Vero2 image and used that instead.

I don´t remember seeing any massage on what image that was written, just that it was complete (I can be wrong here?).
Once booted with the SD card it replaced my current install without a warning or a possibility to stop it.

Luckily I have some scripts saved to recreate settings, fstabm custom video nodes etc, so it didn´t take to long to restore.

Almost forgot my initial question:
Whats the advised way to install google apps?
I’m only experienced in flashing a gapps .zip file in recovery mode like a version of these opengapps.
Is there a recovery like twrp or clockworkmod recovery we can enter to flash zips?

Android runs entirely off the SD card, so if you image the card with the Android image, you won’t lose anything on the NAND.

Check out the Wiki – that is the expected behaviour as OSMC is the preferred OS to boot to. You then switch to Android once OSMC has booted.

Interesting question. Currently, after installation, if the installer used is not a factory version (none of the ones on the website are), then the SD card boot files are removed, so that if you reinsert the card, you don’t kick off another installation by mistake or end up triggering a reinstallation if you leave the SD card inserted. See:

#ifndef FACTORYV2
    system("rm -rf /mnt/boot/*"); /* Trash existing files */
#endif

But if you insert a freshly formatted card in to the device, it is possible to erase the contents of the NAND. I would assume that this is no accident, as you have chosen to go image the card and prepare it for the device.

As per your recommendation, I added a 60 second warning before the installer formats the NAND which gives them time to power off the unit and remove their SD card if they wish to do so. This will be available in future installers.

Not sure of the ‘best way’. Things like recovery and clockworkmod probably won’t work as they won’t expect the Android installation to be on an SD card, and they’ll probably try and install the ZIP to the NAND containing OSMC.

As Android is on the SD card, it may be possible to just mount the SD card’s system partition and put the apps in directly. You could boot to OSMC and then mount /dev/mmcblk0p2 (which is system if I remember correctly).

I’ll have a look at the best way to get Google Apps on soon.

I downloaded the Android image this afternoon and installed using the OSMC Installer to a Scandisk 32Gb Extreme UHS-1 Card.

The Vero2 has just been sitting there for the last hour and a half or so booting & showing the “Please stand by” message.

No sign of it on the network yet. Not sure what, if anything, is happening with it.

If I just unplug it & try another reboot, will it screw something up, or is that the best solution?

Thanks,
Graham

It won’t screw up your OSMC installation, might cause some issues that require Android to be reimaged.

I suggest trying another SD card.

Sam

Thanks, Sam.

Graham
PS The card was fresh, straight out of the box.

Understood, but my suggestion would be to try another card, and if that fails too, check how you imaged the card. On an 8GB SanDisk Class 10, the Android first boot took around 10 minutes for me.

Sam

Absolutely, but how can I be sure I have the Android image? I tough I had.
(Since other users have succeed, I must have done something wrong, so we can drop it)

Yes, I understand, I try to reboot into Android via SSH commands, but I get to some kind of Android recovery menu with a few options (will take a picture of the screen and post next time I see it)

This is a great improvement, will probably wait for this to go in before I try with a new Android image.