Anybody else using CinemaVision add-on with Vero 4K?


#1

Is anybody here using the CinemaVision add-on with the Vero 4k? If so, does it work well for you or do you experience occasional reboots?


#2

For some reason, running a CV sequence is often hit and miss. At some point during the trailers or bumpers it’ll occasionally end abruptly, resulting in the OSMC “sad face” indicating that something went wrong. A few times I could hear the audio from a trailer or bumper but the screen was black. Other times the CV sequence is fine from start to finish.

Does anyone else use a Vero 4K by chance who can offer some insight as to what could be happening?


#3

Logs obtained at the time of the issue will offer the most insight.


#4

@sam_nazarko or anyone. Since the March update the CinemaVision add-on was behaving relatively well, however with yesterday’s April update, the movie trailers often play with a black screen only, though the audio is playing fine. I noticed that if I touch anything on the remote that activates the GUI (for example, the progress bar, player process information, player debug, etc) that the video will immediately appear.

For a bit of context in terms of what I have CinemaVision doing, here is how I have my sequences set up. In the sequence:

  1. A json command is first sent to the Vero 4K to set ADJUST DISPLAY REFRESH RATE to OFF. (This is to eliminate the time it takes for my projector to sync up between each trailer/video bumper. All trailers are downloaded from hd-trailers.net).

  2. Next, trivia slides are shown with a movie soundtrack (mp3) playing in the background.

  3. When everyone is ready I’ll select Next on the remote to then continue the sequence, which is to then reduce the lighting and begin playback of the queue of movie trailers (the ones I download are always 1080p @ 23.976 fps, AAC stereo). The refresh rate of my projector will stay at 59.94, as it should. At this point the screen will go black, as it should, but will then stay black while the trailer plays. (Sometimes the first trailer will play fine, but then when the screen goes black after the first trailer ends it will stay black until I manually engage the GUI to “awaken” it).

I noticed that unless I bring up something manually on the screen it will tend to stay a black/blank screen while playing the remaining trailers and video bumpers in the queue, however when it gets to the json command (immediately before the main feature) to switch the ADJUST DISPLAY REFRESH RATE setting to ON START / STOP that the main feature will play perfectly fine once the projector syncs up.

Any idea what could be happening? Is there a setting somewhere that can be enabled to tell the screen to “wake up” before each video in a queue is played?


#5

As requested previously, we need logs to get a better understanding of the problem. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/


#6

The thing is, when debug logging is enabled the issue no longer presents itself because debug logging constantly refreshes info on the GUI (log location, memory and CPU usage). As mentioned previously, the video becomes immediately visible when anything happens with the GUI, otherwise it is black/blank and I can only hear audio.

At any rate, the log can be found at:

https://paste.osmc.tv/uxayojulaz

Edit: @sam_nazarko and @ActionA. Here is another file with the onscreen debug log text hidden (thanks @bmillham). The first trailer was visible, but the rest of the trailers and video bumpers were black/blank (only audio could be heard). This time the screen remained black/blank even after Adjust Display Refresh Rate was turned back on for the movie:

https://paste.osmc.tv/obojosujas


#7

You can turn off the GUI debug display messages by changing:

<loglevel>2</loglevel> to  <loglevel>1</loglevel>

in advancedsettings.xml.

EDIT: My bad, fixed the formatting…


#8

@MidnightWatcher: Which Version of Cinemavision do you use ? I stell get the same error as before (some python error). My Seqeunce is empty, except for “Feature”. All options are turend off…

Can you share your settings ? Maybe you remove some passwords before :wink:


#9

I use version 1.1.0, the latest official version from the repository. Not sure what settings you’re asking for but a python error sounds like you’d need a debugging log.

https://cinemavision.tv/guides/kodi-entertainment-center/how-to-create-and-upload-logs/


#10

How about this. Is anyone using CinemaVision with a Vero 4K and not experiencing this issue with the April update?

I’ve tried everything I can think of – used different skins, reduced the wait time before playing the next video in the playlist/queue to zero, disabled the json commands and kept vsync on – but the only thing that still works is activating the GUI.


#11

Does disabling hardware acceleration resolve the issue?


#12

Good question, I just tried it with hardware acceleration disabled and it works properly.


#13

Thanks, that’s useful to know


#14

If there’s anything you’d like me to test out let me know.


#15

Well, isn’t this interesting. I just updated my Onkyo receiver’s firmware with a new version that was just released, and it seems like this issue is resolved. I’ll do more testing but so far so good!


#16

Did more testing and though improved it’s now hit and miss. Not sure why. Same result with the June update as well.


#17

Quick question: if you plug Vero 4K directly in to the TV, does the issue completely go?


#18

Vero 4K > Onkyo TR555 > Epson 5030UB. Hit and miss, usually miss with one or more items in the playlist.

Vero 4K > Epson 5030UB. Hit and miss, usually miss with one or more items in the playlist.

So it makes no difference. For what it’s worth, I had the Raspberry Pi prior to the Vero 4K and never had the issue, which leads me to conclude that when playing videos in a playlist the Vero 4K isn’t doing something to let the display know that a video is playing on screen. I need to engage the GUI to “wake” it up, either OSMC’s volume bar, progress bar, player process information, player debug, etc.


#19

Hi Sam, any update on a possible fix? I’ll be having a few movie nights soon for friends and would love to do some trailers and bumpers with CinemaVision if possible.


#20

I think I’d need to rip a file out of the add-on to see what’s going.
Is there any way I can do that / record something?

Sam