App Store button not working

I’ve just updated to RC3 and wanted to investigate getting samba installed from the App Store. I ran the OSMC settings program and while every other item on the menu works, when I clicked on the App Store button nothing happened.

Any tips?

Did you originally install from the noobs installer or using the osmc installer ?

If it was the noobs installer you may have used an older version with a bug. If so you need to edit cmdline.txt and make a slight change:

sudo nano /boot/cmdline.txt

Find the section of the line that says osmcdev=rbp and change it to osmcdev=rbp1 or osmcdev=rbp2 depending on whether you have a Pi 1 or Pi 2, save the file and reboot.

If this is already correct, then your problem is something else.

If this doesn’t solve the problem or you didn’t use a noobs install, please enable debug mode in Kodi, try to go into the App store, then when it fails use the log uploader to upload your Kodi log.


1 Like

Would also like to know ‘when’ you installed. This NOOBS bug should have been fixed quite a while ago.


I edited it from:

root=/dev/mmcblk0p2 rootfstype=ext4 rootwait quiet osmcdev=rbp splash=/sbin/splash_early

root=/dev/mmcblk0p2 rootfstype=ext4 rootwait quiet osmcdev=rbp2 splash=/sbin/splash_early

After a reboot it all worked as expected. Thanks.

This would help so we know if it’s fixed in NOOBS.

I’ve never installed from NOOBS. I originally installed OSMC from alpha 4 (I believe). Since then I’ve used the updater system to move through the RCs.

This will not work. You cannot upgrade from an Alpha build.

We did everything we could to make it very clear that upgrading alpha 4 would never result in a stable and bug free RC+. You’ve now been able to workaround this inherent bug but, there WILL be more as we approach final. You really need to re-install with a new RC2 image to move forward without further issues and enjoy the very best experience that OSMC can provide…

Support of alpha 4 installs is not going to be provided.

Gotcha. Then I have imaged the RC1 img which was posted here at