App store doesn't open

Hi,

I’ve just installed OSMC on an rpi2.
I wanted to install the Tvheadend server so I visited Settings > My OSMC
But the App Store button on the circular menu isn’t doing anything. It just clicks!

I misunderstood post #1 and post #2 looking for a solution. I thought osmcdev was missing entirely from my config.txt, but I see now it should be in cmdline.txt, which it is, correctly set to osmcdev=rpi2. Also, that pertains to a bug with a NOOBS installation and I have used the official installer instead.

There is nothing in the general kodi.log so I’m going to switch on debugging tonight and see if I can obtain more detail.

Any ideas in the meantime?

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Well as promised I switched on the debugging last night and tried to reproduce the fault, which had survived several restarts. But I can now access the App Store normally. I’ve switched off debugging and rebooted and it still works.

I’m hardly confident the logging is a factor, although on a previous system Confluence used to hang during startup as it connected to the TV server if debugging was enabled…

For what it’s worth it the only peripherals were the HDMI to the TV and a Logitech Unified Keyboard/Mouse USB dongle. I’ve just moved over from ArchArm so I’ve nothing to compare to in terms of previous version behavior.

For me at least - SOLVED.