Cannot access app store

Hi there
I’ve been trying to access the App Store but it has been impossible.
Meanwhile, my kodi.log gives me this:

16:31:06 T:2866877472   DEBUG: OSMC APFStore store : APF data URL: http://download.osmc.tv/apps/rbp
16:31:06 T:2937058336   DEBUG: PushCecKeypress - received key  b duration 150
16:31:06 T:2866877472   DEBUG: OSMC APFStore store : JSON couldnt be read: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
                                            <html><head>
                                            <title>404 Not Found</title>
                                            </head><body>
                                            <h1>Not Found</h1>
                                            <p>The requested URL /osmc/download/apps/rbp was not found on this server.</p>
                                            <hr>
                                            <address>Apache/2.4.7 (Ubuntu) Server at 46.37.189.135 Port 80</address>
                                            </body></html>
16:31:06 T:2866877472   DEBUG: OSMC APFStore store : apf_store.get_list_from_sam [0.328961133957]  returns: failed
16:31:06 T:2866877472   DEBUG: OSMC APFStore store : Failed to retrieve osmcdev= from /proc/cmdline
16:31:06 T:2866877472   DEBUG: OSMC APFStore store : Failed to retrieve JSON apf data
16:31:06 T:2866877472   DEBUG: OSMC APFStore scriptmoduleosmcsettingapfstore.run -nowait

And, well, apparently the folder download.osmc.tv/apps/ has indeed been replaced by a “rbp1” and “rbp2” after the release of the new model.

Where can I change the script to go fetch the correct URL?

You have likely installed via NOOBS from what I can see.

I forgot to set specific rbp1 or rbp2 settings as appropriate in cmdline.txt. This has been fixed in this commit and I am waiting for the NOOBS maintainer to pick up this change:

For now, you can manually edit osmcdev= in /boot/cmdline.txt. Change it to rbp1 or rbp2 (depending on your platform). The App Store will then start working

Sam

Thanks a lot, it’s working now :slight_smile: