ATV HDD Install Stuck

Came here to figure out why the HDD installation sat at the last portion of the installation screen. Any ETA as to when the HDD installation will be good to go?

Hi @Brett_Hardin

HDD install is working.
I’ve done it multiple times since the new HDD Installer was released.

What do you mean by “last portion” ?
You will need to be be more specific on exactly what steps you used, and the result.

Not sure what the OP’s issue was, but for me it gets stuck at the the last part of “installing files” screen. Progress bar fills, but then it doesn’t go any further.

Is the installer/bootable media creator still supposed to be pointing to the same december update that didn’t work? Because that’s the only one I see when I use it.

The new HDD installer failed for me.

As was the case in the past, the My OSMC addon was unable to start…

I installed the new image using the DD method and all was fine.

I’m not fussed, it takes only about 20 seconds longer!

@Sean_Burke is correct. The screen which says, “installing files” is the screen where the installation seems to get stuck. I don’t know how to ssh at this point in order to get logs.

So maybe I’m missing something. I just downloaded the latest distro for HDD install. Created the USB stick, plugged it in, and restated. It installs and gives me the “installed successfully” screen. I remove the usb stick and restart the ATV.

It then goes back into formatting device and installing again. What am I missing?

Are you simply restarting or powering down as the instructions advise?

Same issue here, using USB install with Jan and Dec versions, both stop installing when the “Installing Files” progress bar is complete, then it just hangs on the screen and never completes the install. Confirmed issue on both my ATV1’s with cystal chip installed. Both were running CrysalUbuntu for last couple years.

I tried to SSH to the unit, but I assume the network isnt initialized yet.

IS there another way to install?

As the unit is totally forzen/stuck and nothing has been loaded, it needs a hard reboot, either from a power cord pull or the apple remote reboot.

I ended up solving the problem by booting with USB, sshing into the box, and then using dd to format the hard disk. This is not the advised installation method however.

I just did the install selecting hdd install from the latest installer. It did not install to hdd, but ran off the usb. When usb unplugged, the hdd was just as before the install.

This is what is downloaded when selecting 2016.01-1-HDD: OSMC_TGT_appletv_20160130-USB.img.gz

The correct image can be found here:
Download and select manually in installer.

Fixed mine, used a 3rd USB which was alot slower for the install…I seem to recall that CrystalUbuntu was prone to this issue also, would take me a while to finally get it installed.

Just setting up the config right now.

Thanks for assistance.

Tried several different usb-sticks, but they all halt on full installing files bar.

Well, I can install it now, but doesnt want to use the Broadcom HD sticks for decoding…I tried both of my units…just doesnt give me the option to enable it…sucks…back to CrystalUbuntu…which was rock solid.

There is no option to disable CrystalHD if it is detected.

The menu option doesn’t work because it is permanently/forced enabled.

I have the same issue. I’m using the latest image “OSMC_TGT_appletv_20160130-HDD.img.gz” and already tried several USB-sticks, even those that was previously perfectly worked for OSMC installation.

Same here guys, tried the OSMC_TGT_appletv_20160130-HDD.img.gz, stuck on the end of Installing files bar.

Hi Guys, after my last post I give up waiting for the install files and removed my flash drive, and then discovered that my previous version on the Hard Drive was untouched and working fine, so I’ll hold out until the fault is corrected.

I’m in the same situation. I have discovered that my previous OSMC installation was working after I have removed USB-stick and restart the Apple TV.

I have already tried to create a USB-stick with OSMC installation under Windows and Mac OS and got the same result.

USB and HDD images are switched in the installer it seems. Selecting HDD gives you USB-install.

I don’t believe this is the case. Can you check your log and show me what mirror is being selected?