ATV1 OSMC boots up with a Reset of sorts

I was using Amber - with “Capitalization/ Not All Caps” for font usage.

Booted up into OSMC theme and when I switched to Amber the above was gone (I’m thinking bunch of other settings might have gone).

Also, Sound output was RESET to something and then I had to choose HDMI after wondering if one of my wires had come loose.

My SMB file share was still browse-able so not everything was Reset. But I am wondering what Survived and what got Reset. Any thoughts?

This was after a Safe Shutdown. I am guilty of a few lazy power offs before but before this specific bootup I did a Shutdown.

So, I’m wondering and curious why this happened?
How to prevent?
What folders/ files to backup to restore such mishaps?

Did you run fsck to fix your lazy power offs?

@sam_nazarko - No. Had no idea we had to do that now.

How and with what command line arguments do I need to run fsck. I went through these threads but still not sure.

rPi - Trying to run fsck via recovery console

I ran these lines:

sudo umount /boot
sudo fsck.hfsplus -f /dev/sda1
sudo mount -o force,rw /dev/sda1 /boot


** The volume untitled appears to be OK.

So, why did I lose some part of “settings” and retained part of them; especially not after a bad shutdown but after a safe shutdown.

If you pull the plug, you can cause the filesystem to be in an incomplete state. It’s not predictable what will persist and what will be corrupted. Despite safe shutdowns afterward, it seemed like you needed to repair your volume. You should also look at repairing the /dev/sda2 partition (ext4) too.


If someone would be kind enough to point me to the Frequently used list of - File System - Maintenance procedures specific to OSMC that would be great and I wouldn’t be searching / doing guess work here.

For now, I’m shutting down using Power Off on my iPhone Kodi Remote App. If I can find a cheap Sub 5/10$ remote shipped from China etc (since I’m not currently in the US) I’d love to set that up with ATV1 OSMC.

Would these kinds work?

Or any other Universal Kodi remote that will play well with OSMC on ATV1?

I did run it many times and I am still facing issues with updating and so on.

osmc@osmc_atv1:/etc/X11$ sudo umount /boot
osmc@osmc_atv1:/etc/X11$ sudo fsck.hfsplus -f /dev/sda1
** /dev/sda1
** Checking HFS Plus volume.
** Checking Extents Overflow file.
** Checking Catalog file.
** Checking Catalog hierarchy.
** Checking volume bitmap.
** Checking volume information.
** The volume untitled appears to be OK.
osmc@osmc_atv1:/etc/X11$ sudo mount -o force,rw /dev/sda1 /boot